aboutsummaryrefslogtreecommitdiffstats
path: root/ui/qt/CMakeLists.txt
diff options
context:
space:
mode:
authorStig Bjørlykke <stig@bjorlykke.org>2016-02-07 22:15:12 +0100
committerStig Bjørlykke <stig@bjorlykke.org>2016-02-08 16:54:12 +0000
commit1b5382caa57555bd73601937d9f08afb179f0228 (patch)
treed8fc81a86a6975afb3dd3c1b0d43c0a90f6448f9 /ui/qt/CMakeLists.txt
parent56a41845e7aada1655553a50abaa64df6817d8d2 (diff)
Qt: Add Show Packet Bytes Dialog
Show selected packet bytes as ASCII, HTML, Image, ISO 8859-1, Raw or UTF-8. Images supported are what's supported by QImage, and HTML supported is what's supported by QTextEdit. Change-Id: I96fc5c5d222c5389078576463cf78d82cf55528d Reviewed-on: https://code.wireshark.org/review/13807 Petri-Dish: Stig Bjørlykke <stig@bjorlykke.org> Reviewed-by: Stig Bjørlykke <stig@bjorlykke.org>
Diffstat (limited to 'ui/qt/CMakeLists.txt')
-rw-r--r--ui/qt/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/ui/qt/CMakeLists.txt b/ui/qt/CMakeLists.txt
index 23758df588..dbfa3ec02e 100644
--- a/ui/qt/CMakeLists.txt
+++ b/ui/qt/CMakeLists.txt
@@ -128,6 +128,7 @@ set(WIRESHARK_QT_HEADERS
search_frame.h
sequence_diagram.h
sequence_dialog.h
+ show_packet_bytes_dialog.h
simple_dialog.h
splash_overlay.h
stats_tree_dialog.h
@@ -278,6 +279,7 @@ set(WIRESHARK_QT_SRC
service_response_time_dialog.cpp
simple_dialog.cpp
simple_statistics_dialog.cpp
+ show_packet_bytes_dialog.cpp
splash_overlay.cpp
sparkline_delegate.cpp
stock_icon.cpp
@@ -401,6 +403,7 @@ set(WIRESHARK_QT_UI
sctp_graph_byte_dialog.ui
search_frame.ui
sequence_dialog.ui
+ show_packet_bytes_dialog.ui
splash_overlay.ui
supported_protocols_dialog.ui
tap_parameter_dialog.ui