aboutsummaryrefslogtreecommitdiffstats
path: root/ui/gtk/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2013-04-25 21:35:54 +0000
committerJörg Mayer <jmayer@loplof.de>2013-04-25 21:35:54 +0000
commit52965244cd4a5bef40b1c24fdbdf9209bfaf5317 (patch)
treef68faa8649ecc7ff771c96b8cb2f194f5901ffcb /ui/gtk/CMakeLists.txt
parent540b4d5f2d39585289c0e24a7772baa557045a2c (diff)
Add GTK3_DEFINITIONS to the compiler flag when building with gtk3
svn path=/trunk/; revision=49038
Diffstat (limited to 'ui/gtk/CMakeLists.txt')
-rw-r--r--ui/gtk/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/ui/gtk/CMakeLists.txt b/ui/gtk/CMakeLists.txt
index 0fa4fb363d..80aec89951 100644
--- a/ui/gtk/CMakeLists.txt
+++ b/ui/gtk/CMakeLists.txt
@@ -218,7 +218,9 @@ if (WERROR)
)
endif()
-if (NOT ENABLE_GTK3)
+if (ENABLE_GTK3)
+ add_definitions(${GTK3_DEFINITIONS})
+else()
add_definitions(
# We are only allowed to include gtk/gtk.h, no other files. When
# violating this with gtk3 the compiler will complain anyway.