aboutsummaryrefslogtreecommitdiffstats
path: root/ui/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2016-10-30 14:07:33 -0700
committerGuy Harris <guy@alum.mit.edu>2016-10-30 22:57:16 +0000
commit03c6937e62b9b35960b65d573399d64b7a8fd147 (patch)
tree1be6af646ca3e97004344962a5225cd18e3f11d5 /ui/Makefile.am
parente3b2b2fdc3e6f2c4f1fd659bc6d045f237527036 (diff)
Have routines for parsing options that affect dissection.
Have them handle -d, -t, --disable-protocol, --disable-heuristic, and --enable-heuristic for TShark and both flavors of Wireshark. Change-Id: I612c276b1f9df8a2092202d23ab3d48be7857e85 Reviewed-on: https://code.wireshark.org/review/18583 Petri-Dish: Guy Harris <guy@alum.mit.edu> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'ui/Makefile.am')
-rw-r--r--ui/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/ui/Makefile.am b/ui/Makefile.am
index 91f189bd05..5a252e32cd 100644
--- a/ui/Makefile.am
+++ b/ui/Makefile.am
@@ -54,6 +54,7 @@ WIRESHARK_UI_SRC = \
commandline.c \
console.c \
decode_as_utils.c \
+ dissect_opts.c \
export_object.c \
export_object_dicom.c \
export_object_http.c \
@@ -99,6 +100,7 @@ WIRESHARK_UI_INCLUDES = \
commandline.h \
console.h \
decode_as_utils.h \
+ dissect_opts.h \
export_object.h \
export_pdu_ui_utils.h \
last_open_dir.h \