aboutsummaryrefslogtreecommitdiffstats
path: root/tools/pidl/Makefile.PL
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2005-09-16 09:31:05 +0000
committerJörg Mayer <jmayer@loplof.de>2005-09-16 09:31:05 +0000
commitfdc91d7e2472fa7f7fe919e3e297e6fd3525c0b3 (patch)
tree44291d3d75e6bccd82557c5fce8ce66e6f17e45c /tools/pidl/Makefile.PL
parentf6264ee8d2c343d608aa21f7a9c2351a7769eb28 (diff)
Add a local copy of pidl, add a README.ethereal to include
minimalistic building and usage instructions. svn path=/trunk/; revision=15836
Diffstat (limited to 'tools/pidl/Makefile.PL')
-rwxr-xr-xtools/pidl/Makefile.PL25
1 files changed, 25 insertions, 0 deletions
diff --git a/tools/pidl/Makefile.PL b/tools/pidl/Makefile.PL
new file mode 100755
index 0000000000..fa250cabc3
--- /dev/null
+++ b/tools/pidl/Makefile.PL
@@ -0,0 +1,25 @@
+use ExtUtils::MakeMaker;
+WriteMakefile(
+ 'NAME' => 'Parse::Pidl',
+ 'VERSION_FROM' => 'lib/Parse/Pidl.pm',
+ 'EXE_FILES' => [ 'pidl' ],
+ 'PMLIBDIRS' => [ 'lib' ],
+ 'test' => { 'TESTS' => 'tests/*.pl' }
+);
+
+sub MY::postamble {
+<<'EOT';
+lib/Parse/Pidl/IDL.pm :: idl.yp
+ yapp -s -m 'Parse::Pidl::IDL' -o 'lib/Parse/Pidl/IDL.pm' idl.yp
+
+doc: pidl.1 pidl.1.html
+
+XSLTPROC=xsltproc
+
+%.1: %.1.xml
+ test -z "$(XSLTPROC)" || $(XSLTPROC) -o $@ http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl $<
+
+%.html: %.xml
+ test -z "$(XSLTPROC)" || $(XSLTPROC) -o $@ http://docbook.sourceforge.net/release/xsl/current/html/docbook.xsl $<
+EOT
+}