aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/transum/CMakeLists.txt
diff options
context:
space:
mode:
authorPascal Quantin <pascal.quantin@gmail.com>2016-12-12 21:42:14 +0100
committerPascal Quantin <pascal.quantin@gmail.com>2016-12-13 08:50:27 +0000
commit693dcd276e556033b1176d16f4ea257ae3e68ea5 (patch)
tree9eea1e83a8e0086c5f5f4d1fc00c4e692c40335e /plugins/transum/CMakeLists.txt
parent862905da1b84e1997e2b2a5d4ae8bbaaedb804de (diff)
Build TRANSUM plugin
Add plugin to autofoo and CMake build systems and fix errors found Add plugin to Windows installer (optional component activated by default) Change-Id: Id1b777bdee04e53076b3291f6fb68d5abad6985d Reviewed-on: https://code.wireshark.org/review/19228 Petri-Dish: Pascal Quantin <pascal.quantin@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Pascal Quantin <pascal.quantin@gmail.com>
Diffstat (limited to 'plugins/transum/CMakeLists.txt')
-rw-r--r--plugins/transum/CMakeLists.txt91
1 files changed, 91 insertions, 0 deletions
diff --git a/plugins/transum/CMakeLists.txt b/plugins/transum/CMakeLists.txt
new file mode 100644
index 0000000000..aa9640790c
--- /dev/null
+++ b/plugins/transum/CMakeLists.txt
@@ -0,0 +1,91 @@
+# CMakeLists.txt
+#
+# Wireshark - Network traffic analyzer
+# By Gerald Combs <gerald@wireshark.org>
+# Copyright 1998 Gerald Combs
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+#
+
+include(WiresharkPlugin)
+
+# Plugin name and version info (major minor micro extra)
+set_module_info(transum 2 0 2 0)
+
+set(DISSECTOR_SRC
+ packet-transum.c
+)
+
+set(DISSECTOR_SUPPORT_SRC
+ decoders.c
+ extractors.c
+)
+
+set(PLUGIN_FILES
+ plugin.c
+ ${DISSECTOR_SRC}
+ ${DISSECTOR_SUPPORT_SRC}
+)
+
+set(CLEAN_FILES
+ ${PLUGIN_FILES}
+)
+
+set_source_files_properties(
+ ${CLEAN_FILES}
+ PROPERTIES
+ COMPILE_FLAGS "${WERROR_COMMON_FLAGS}"
+)
+
+include_directories(${CMAKE_CURRENT_SOURCE_DIR})
+
+register_dissector_files(plugin.c
+ plugin
+ ${DISSECTOR_SRC}
+ ${DISSECTOR_SUPPORT_SRC}
+)
+
+add_plugin_library(transum)
+
+install(TARGETS transum
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/${CPACK_PACKAGE_NAME}/plugins/${CPACK_PACKAGE_VERSION} NAMELINK_SKIP
+ RUNTIME DESTINATION ${CMAKE_INSTALL_LIBDIR}/${CPACK_PACKAGE_NAME}/plugins/${CPACK_PACKAGE_VERSION}
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}/${CPACK_PACKAGE_NAME}/plugins/${CPACK_PACKAGE_VERSION}
+)
+
+file(GLOB DISSECTOR_HEADERS RELATIVE "${CMAKE_CURRENT_SOURCE_DIR}" "*.h")
+CHECKAPI(
+ NAME
+ transum
+ SWITCHES
+ -g abort -g termoutput -build
+ SOURCES
+ ${DISSECTOR_SRC}
+ ${DISSECTOR_SUPPORT_SRC}
+ ${DISSECTOR_HEADERS}
+)
+
+#
+# Editor modelines - http://www.wireshark.org/tools/modelines.html
+#
+# Local variables:
+# c-basic-offset: 8
+# tab-width: 8
+# indent-tabs-mode: t
+# End:
+#
+# vi: set shiftwidth=8 tabstop=8 noexpandtab:
+# :indentSize=8:tabSize=8:noTabs=false:
+#