aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/rlm/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2004-03-25 11:21:07 +0000
committerGuy Harris <guy@alum.mit.edu>2004-03-25 11:21:07 +0000
commita1467c86e11071c4bd0eb71133684434f48cf094 (patch)
tree5e3c4e04a24380aac59d752a21708a2afa46a051 /plugins/rlm/Makefile.am
parenta6ed2d499af391480d9853833e22f153c502dc4b (diff)
From Duncan Sargeant: Cisco SS7 RUDP, RLM, and Session Management
support. svn path=/trunk/; revision=10480
Diffstat (limited to 'plugins/rlm/Makefile.am')
-rw-r--r--plugins/rlm/Makefile.am44
1 files changed, 44 insertions, 0 deletions
diff --git a/plugins/rlm/Makefile.am b/plugins/rlm/Makefile.am
new file mode 100644
index 0000000000..d396030698
--- /dev/null
+++ b/plugins/rlm/Makefile.am
@@ -0,0 +1,44 @@
+# Makefile.am
+# Automake file for Cisco SS7 Redundant Link Management dissector
+# Copyright 2004, Duncan Sargeant <dunc-ethereal@rcpt.to>
+#
+# $Id: Makefile.am,v 1.1 2004/03/25 11:21:07 guy Exp $
+#
+# Ethereal - Network traffic analyzer
+# By Gerald Combs <gerald@ethereal.com>
+# Copyright 1998 Gerald Combs
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+#
+
+INCLUDES = -I$(top_srcdir)
+
+plugindir = @plugindir@
+
+plugin_LTLIBRARIES = rlm.la
+rlm_la_SOURCES = packet-rlm.c moduleinfo.h
+rlm_la_LDFLAGS = -module -avoid-version
+
+# Libs must be cleared, or else libtool won't create a shared module.
+# If your module needs to be linked against any particular libraries,
+# add them here.
+LIBS =
+
+CLEANFILES = \
+ rlm \
+ *~
+
+EXTRA_DIST = \
+ Makefile.nmake