aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/mate/Makefile.am
diff options
context:
space:
mode:
authorLars Roland <Lars.Roland@gmx.net>2004-12-11 01:00:17 +0000
committerLars Roland <Lars.Roland@gmx.net>2004-12-11 01:00:17 +0000
commit86d7ed9bae34b2c68c5ba9ef209ecd6050d7051a (patch)
treed48333a163cc0d71fa18091824988f0e429210d6 /plugins/mate/Makefile.am
parentea67e4cfabfdd0d24a11f9ed2a45ce2a29f84252 (diff)
New Plugin from Luis Ontanon:
MATE -- Meta Analysis and Tracing Engine Won't be compiled by default. It is still not possible to link the plugin on Win32. svn path=/trunk/; revision=12716
Diffstat (limited to 'plugins/mate/Makefile.am')
-rw-r--r--plugins/mate/Makefile.am44
1 files changed, 44 insertions, 0 deletions
diff --git a/plugins/mate/Makefile.am b/plugins/mate/Makefile.am
new file mode 100644
index 0000000000..2b6fd02673
--- /dev/null
+++ b/plugins/mate/Makefile.am
@@ -0,0 +1,44 @@
+# Makefile.am
+# Automake file for MATE Ethereal plugin
+#
+# $Id$
+#
+# Ethereal - Network traffic analyzer
+# By Gerald Combs <gerald@ethereal.com>
+# Copyright 1998 Gerald Combs
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+#
+
+INCLUDES = -I$(top_srcdir)
+
+plugindir = @plugindir@
+
+plugin_LTLIBRARIES = mate.la
+mate_la_SOURCES = moduleinfo.h mate.h mate_util.h packet-mate.c mate_runtime.c mate_setup.c mate_util.c mate_plugin.c
+mate_la_LDFLAGS = -module -avoid-version
+mate_la_LIBADD = @PLUGIN_LIBS@
+
+# Libs must be cleared, or else libtool won't create a shared module.
+# If your module needs to be linked against any particular libraries,
+# add them here.
+LIBS =
+
+CLEANFILES = \
+ mate \
+ *~
+
+EXTRA_DIST = \
+ Makefile.nmake