aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/m2m/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2017-09-30 17:48:00 +0100
committerAnders Broman <a.broman58@gmail.com>2017-10-01 16:05:05 +0000
commit6e24d5f69059dd10fd7b5752a9050b79d936a1d4 (patch)
tree3d6e310bf223c87a3a39ae0d73f43668f514b711 /plugins/m2m/CMakeLists.txt
parente155e9159988a96a85ad1f495a7ce24473e08456 (diff)
Unsplit "m2m" plugin (wimax mac-to-mac encapsulation)
... not to be confused with "machine-to-machine". M2M seems to be a simple Wimax encapsulation protocol developed by Intel. It's not documented publicly anywhere that I can find. The boilerplate to code ratio is huge and it even includes a complete source file from the Wimax dissector (yuck). Put it in the Wimax plugin instead. Minor version number bump for wimax plugin. Change-Id: I2694339dfe89be334093b257a5b34d1577f4dc20 Reviewed-on: https://code.wireshark.org/review/23790 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'plugins/m2m/CMakeLists.txt')
-rw-r--r--plugins/m2m/CMakeLists.txt90
1 files changed, 0 insertions, 90 deletions
diff --git a/plugins/m2m/CMakeLists.txt b/plugins/m2m/CMakeLists.txt
deleted file mode 100644
index 63c88d2871..0000000000
--- a/plugins/m2m/CMakeLists.txt
+++ /dev/null
@@ -1,90 +0,0 @@
-# CMakeLists.txt
-#
-# Wireshark - Network traffic analyzer
-# By Gerald Combs <gerald@wireshark.org>
-# Copyright 1998 Gerald Combs
-#
-# This program is free software; you can redistribute it and/or
-# modify it under the terms of the GNU General Public License
-# as published by the Free Software Foundation; either version 2
-# of the License, or (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-#
-
-include(WiresharkPlugin)
-
-# Plugin name and version info (major minor micro extra)
-set_module_info(m2m 1 1 0 0)
-
-set(DISSECTOR_SRC
- packet-m2m.c
-)
-
-set(DISSECTOR_SUPPORT_SRC
- wimax_tlv.c
-)
-
-set(PLUGIN_FILES
- plugin.c
- ${DISSECTOR_SRC}
- ${DISSECTOR_SUPPORT_SRC}
-)
-
-set(CLEAN_FILES
- ${PLUGIN_FILES}
-)
-
-set_source_files_properties(
- ${CLEAN_FILES}
- PROPERTIES
- COMPILE_FLAGS "${WERROR_COMMON_FLAGS}"
-)
-
-include_directories(${CMAKE_CURRENT_SOURCE_DIR})
-
-register_dissector_files(plugin.c
- plugin
- ${DISSECTOR_SRC}
- ${DISSECTOR_SUPPORT_SRC}
-)
-
-add_plugin_library(m2m)
-
-install(TARGETS m2m
- LIBRARY DESTINATION ${PLUGIN_INSTALL_LIBDIR} NAMELINK_SKIP
- RUNTIME DESTINATION ${PLUGIN_INSTALL_LIBDIR}
- ARCHIVE DESTINATION ${PLUGIN_INSTALL_LIBDIR}
-)
-
-file(GLOB DISSECTOR_HEADERS RELATIVE "${CMAKE_CURRENT_SOURCE_DIR}" "*.h")
-CHECKAPI(
- NAME
- m2m
- SWITCHES
- -g abort -g termoutput -build
- SOURCES
- ${DISSECTOR_SRC}
- ${DISSECTOR_SUPPORT_SRC}
- ${DISSECTOR_HEADERS}
-)
-
-#
-# Editor modelines - http://www.wireshark.org/tools/modelines.html
-#
-# Local variables:
-# c-basic-offset: 8
-# tab-width: 8
-# indent-tabs-mode: t
-# End:
-#
-# vi: set shiftwidth=8 tabstop=8 noexpandtab:
-# :indentSize=8:tabSize=8:noTabs=false:
-#