aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/gryphon/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2009-11-07 10:07:00 +0000
committerJörg Mayer <jmayer@loplof.de>2009-11-07 10:07:00 +0000
commit9ee31d1d0e9a10ddb326bc7b23c22dc99bac7f6c (patch)
tree7e19b692aaacf4e9017a30429e79626a73f71a10 /plugins/gryphon/CMakeLists.txt
parentf6dfb9f323f6253c8c0470b8824d8846f5c578ab (diff)
cmake will now honor -Werror if configured (default: on)
svn path=/trunk/; revision=30852
Diffstat (limited to 'plugins/gryphon/CMakeLists.txt')
-rw-r--r--plugins/gryphon/CMakeLists.txt18
1 files changed, 15 insertions, 3 deletions
diff --git a/plugins/gryphon/CMakeLists.txt b/plugins/gryphon/CMakeLists.txt
index dddf7b9087..f138e124aa 100644
--- a/plugins/gryphon/CMakeLists.txt
+++ b/plugins/gryphon/CMakeLists.txt
@@ -30,6 +30,18 @@ set(PLUGIN_FILES
${DISSECTOR_SRC}
)
+set(CLEAN_FILES
+ ${PLUGIN_FILES}
+)
+
+if (WERROR)
+ set_source_files_properties(
+ ${CLEAN_FILES}
+ PROPERTIES
+ COMPILE_FLAGS -Werror
+ )
+endif()
+
include_directories(${CMAKE_CURRENT_SOURCE_DIR})
register_dissector_files(plugin.c
@@ -48,8 +60,8 @@ add_library(gryphon MODULE
target_link_libraries(gryphon epan)
install(TARGETS gryphon
- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
- RUNTIME DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
- ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
+ RUNTIME DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}
)