aboutsummaryrefslogtreecommitdiffstats
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2003-11-20 23:34:31 +0000
committerGuy Harris <guy@alum.mit.edu>2003-11-20 23:34:31 +0000
commit9687947b5ff4edcfde5c2a04e7bacb74e67d7609 (patch)
tree20877cc6d4d81c8aa37c92cd3a4ed5bfb1b5aeef /gtk/Makefile.am
parentbb0b226ca63e88e35e0eb86e1823f864693fc642 (diff)
From Lars Roland:
- added a pointer to raw rtp data to _rtp_info that can be used by taps; - RTP packets are passed to the tap queue only if they are not error packets (so that you don't need to filter out ICMP packets) - use that pointer in rtp_stream, so it handles packets with padding, and should handle RTP packets fragmented across lower-level packets - moved rtp_stream from tap sources to normal files (prevents on-start-up registration of the rtp_stream tap listener) - rtp_stream tap gets registered/unregistered with the "RTP Streams" dialog box i.e. the tap is registered as long as the dialog box is open. Alternatively, it is de-/registered on demand if RTP Analysis is called directly on a packet. - rtp_stream tap listener no longer uses a filter in dissection ` and does not need to have a proto tree being built. (performance increase) - fixed: RTP Streams list will get updated in real time if the dialog box is open while a redissection takes place. svn path=/trunk/; revision=9051
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index 65ff9eea71..32a394c9ec 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -1,7 +1,7 @@
# Makefile.am
# Automake file for the GTK interface routines for Ethereal
#
-# $Id: Makefile.am,v 1.76 2003/11/19 00:02:42 ulfl Exp $
+# $Id: Makefile.am,v 1.77 2003/11/20 23:34:30 guy Exp $
#
# Ethereal - Network traffic analyzer
# By Gerald Combs <gerald@ethereal.com>
@@ -49,7 +49,6 @@ ETHEREAL_TAP_SRC = \
rpc_progs.c \
smb_stat.c \
rtp_analysis.c \
- rtp_stream.c \
rtp_stream_dlg.c \
wsp_stat.c
@@ -129,6 +128,7 @@ libui_a_SOURCES = \
proto_hier_stats_dlg.h \
proto_hier_stats_dlg.c \
rtp_analysis.h \
+ rtp_stream.c \
rtp_stream.h \
rtp_stream_dlg.h \
service_response_time_table.c \
@@ -220,6 +220,7 @@ libui_a_SOURCES = \
proto_hier_stats_dlg.h \
proto_hier_stats_dlg.c \
rtp_analysis.h \
+ rtp_stream.c \
rtp_stream.h \
rtp_stream_dlg.h \
service_response_time_table.c \