aboutsummaryrefslogtreecommitdiffstats
path: root/epan/ftypes/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2008-07-02 01:44:30 +0000
committerGuy Harris <guy@alum.mit.edu>2008-07-02 01:44:30 +0000
commita04774395fbfa44a90f0c217cf2ab85625b1ea9d (patch)
tree8ea9e8c8e701741d179fd1a61f2927dfb49af0d5 /epan/ftypes/Makefile.am
parent40773753adb08df3eebefabfae29a28783fe5b48 (diff)
Add Makefile.common files for epan/dfilter and epan/ftypes.
Add checkapi rules to Makefile.am files. svn path=/trunk/; revision=25656
Diffstat (limited to 'epan/ftypes/Makefile.am')
-rw-r--r--epan/ftypes/Makefile.am22
1 files changed, 7 insertions, 15 deletions
diff --git a/epan/ftypes/Makefile.am b/epan/ftypes/Makefile.am
index c0b6665e97..67f39d22c6 100644
--- a/epan/ftypes/Makefile.am
+++ b/epan/ftypes/Makefile.am
@@ -6,7 +6,6 @@
# By Gerald Combs <gerald@wireshark.org>
# Copyright 1998 Gerald Combs
#
-#
# This program is free software; you can redistribute it and/or
# modify it under the terms of the GNU General Public License
# as published by the Free Software Foundation; either version 2
@@ -25,6 +24,8 @@ if HAVE_WARNINGS_AS_ERRORS
AM_CFLAGS = -Werror
endif
+include Makefile.common
+
noinst_LTLIBRARIES = libftypes.la
CLEANFILES = \
@@ -37,23 +38,14 @@ MAINTAINERCLEANFILES = \
INCLUDES = -I$(srcdir)/../.. -I$(srcdir)/..
-libftypes_la_SOURCES = \
- ftypes.c \
- ftypes.h \
- ftypes-int.h \
- ftype-bytes.c \
- ftype-double.c \
- ftype-integer.c \
- ftype-ipv4.c \
- ftype-guid.c \
- ftype-none.c \
- ftype-pcre.c \
- ftype-string.c \
- ftype-time.c \
- ftype-tvbuff.c
+libftypes_la_SOURCES = $(NONGENERATED_C_FILES) $(NONGENERATED_HEADER_FILES)
libftypes_la_LIBADD = @GLIB_LIBS@ @PCRE_LIBS@
EXTRA_DIST = \
+ Makefile.common \
Makefile.nmake
+checkapi:
+ $(PERL) ../../tools/checkAPIs.pl -g termoutput \
+ $(NONGENERATED_C_FILES)