aboutsummaryrefslogtreecommitdiffstats
path: root/epan/ftypes/Makefile.am
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-02-22 06:21:53 +0000
committerJoão Valverde <j@v6e.pt>2016-03-01 19:23:39 +0000
commit6b54fbf3bfb7a3b0519637d01fa36bba8cec9c98 (patch)
treeeb9ce7199c857fe314da04cabd448e9381e451ac /epan/ftypes/Makefile.am
parent5da2b437035dbd478293caa1c9242fe2e37924e6 (diff)
CMake: Add more structure to libwireshark build
Smaller epan/CMakeLists.txt is easier to work with and this structure is well suited to CMake. It should make it easier to manage and configure each epan module differently if necessary. Change-Id: Ia649db3b7dcd405aa43dbdba3288699d5e375229 Reviewed-on: https://code.wireshark.org/review/14068 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Peter Wu <peter@lekensteyn.nl> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'epan/ftypes/Makefile.am')
-rw-r--r--epan/ftypes/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/epan/ftypes/Makefile.am b/epan/ftypes/Makefile.am
index 96a586f2ad..fd5f0b90bb 100644
--- a/epan/ftypes/Makefile.am
+++ b/epan/ftypes/Makefile.am
@@ -38,7 +38,8 @@ libftypes_la_SOURCES = $(NONGENERATED_C_FILES) $(NONGENERATED_HEADER_FILES)
EXTRA_DIST = \
Makefile.common \
- Makefile.nmake
+ Makefile.nmake \
+ CMakeLists.txt
checkapi:
$(PERL) $(top_srcdir)/tools/checkAPIs.pl -g termoutput -build \