aboutsummaryrefslogtreecommitdiffstats
path: root/epan/dissectors/asn1/ess/Makefile.am
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-06-21 05:06:23 +0100
committerJoão Valverde <j@v6e.pt>2016-06-30 11:04:17 +0000
commita16d401b25c85ffb7fde6c46b51cb7048112f885 (patch)
tree71ba692edcdb6f2a10ed566e18bcfbbc456cfad1 /epan/dissectors/asn1/ess/Makefile.am
parentf6c5cf953212248cbc680ef0d9b2f852cbfdb951 (diff)
Remove Makefile.common files
Now that nmake build system has been removed they are not needed anymore. Change-Id: I88075f955bb4349185859c1af4be22e53de5850f Reviewed-on: https://code.wireshark.org/review/16050 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'epan/dissectors/asn1/ess/Makefile.am')
-rw-r--r--epan/dissectors/asn1/ess/Makefile.am39
1 files changed, 36 insertions, 3 deletions
diff --git a/epan/dissectors/asn1/ess/Makefile.am b/epan/dissectors/asn1/ess/Makefile.am
index 11932c53a4..b03903c01d 100644
--- a/epan/dissectors/asn1/ess/Makefile.am
+++ b/epan/dissectors/asn1/ess/Makefile.am
@@ -16,7 +16,40 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-
-include ../Makefile.preinc
-include Makefile.common
include ../Makefile.inc
+
+PROTOCOL_NAME=ess
+
+EXT_ASN_FILE_LIST =
+
+ASN_FILE_LIST = \
+ ExtendedSecurityServices.asn
+
+# The packet-$(PROTOCOL_NAME)-template.h and $(PROTOCOL_NAME).asn
+# files do not exist for all protocols: Please add/remove as required.
+EXTRA_DIST = \
+ $(EXTRA_DIST_COMMON) \
+ $(ASN_FILE_LIST) \
+ packet-$(PROTOCOL_NAME)-template.c \
+ packet-$(PROTOCOL_NAME)-template.h \
+ $(PROTOCOL_NAME).cnf
+
+SRC_FILES = \
+ $(EXTRA_DIST) \
+ $(EXT_ASN_FILE_LIST)
+
+A2W_FLAGS= -b -k -C
+
+EXTRA_CNF= \
+ $(builddir)/../cms/cms-exp.cnf \
+ $(builddir)/../x509af/x509af-exp.cnf \
+ $(builddir)/../x509ce/x509ce-exp.cnf
+
+$(builddir)/../cms/cms-exp.cnf:
+ (cd $(builddir)/../cms && $(MAKE_CNF_EXPORT))
+
+$(builddir)/../x509af/x509af-exp.cnf:
+ (cd $(builddir)/../x509af && $(MAKE_CNF_EXPORT))
+
+$(builddir)/../x509ce/x509ce-exp.cnf:
+ (cd $(builddir)/../x509ce && $(MAKE_CNF_EXPORT))