aboutsummaryrefslogtreecommitdiffstats
path: root/epan/dissectors/Makefile.am
diff options
context:
space:
mode:
authorEthan Young <imfargo@gmail.com>2016-12-18 15:37:56 -0500
committerMichael Mann <mmann78@netscape.net>2016-12-20 19:27:38 +0000
commitcaadaaf62317a88f99373d9095b827102999e4e3 (patch)
tree80ea1209f594bf1faa03fb093be15b81cc38df0b /epan/dissectors/Makefile.am
parentb7ee557d88841bc77f65c1fdc8b70ee4751624d6 (diff)
Make EAPOL packet types into a dissector table.
This decouples EAPOL from the few dissectors it needs to call based on packet type and moves registration to the dissectors themselves. Change-Id: Ia8412fe33370f4aeece52c2c80cda7f140a950cf Reviewed-on: https://code.wireshark.org/review/19328 Petri-Dish: Michael Mann <mmann78@netscape.net> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Michael Mann <mmann78@netscape.net>
Diffstat (limited to 'epan/dissectors/Makefile.am')
-rw-r--r--epan/dissectors/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/epan/dissectors/Makefile.am b/epan/dissectors/Makefile.am
index 090aa39173..1daedda589 100644
--- a/epan/dissectors/Makefile.am
+++ b/epan/dissectors/Makefile.am
@@ -1542,6 +1542,7 @@ DISSECTOR_INCLUDES = \
packet-erf.h \
packet-e164.h \
packet-e212.h \
+ packet-eapol.h \
packet-edonkey.h \
packet-eigrp.h \
packet-epmd.h \