aboutsummaryrefslogtreecommitdiffstats
path: root/epan/dissectors/Makefile.am
diff options
context:
space:
mode:
authorMartin Kaiser <wireshark@kaiser.cx>2013-06-21 00:08:20 +0000
committerMartin Kaiser <wireshark@kaiser.cx>2013-06-21 00:08:20 +0000
commit35708dfd139b3e634ce95f24c6ff9aba3fb7f82b (patch)
treec98940abea6e76179224ae3a5ba56b76e004c78d /epan/dissectors/Makefile.am
parentde10bc6b5e23fee484c550cf71836f4368860699 (diff)
create libfiledissectors.a during the autotools build
svn path=/trunk/; revision=50097
Diffstat (limited to 'epan/dissectors/Makefile.am')
-rw-r--r--epan/dissectors/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/epan/dissectors/Makefile.am b/epan/dissectors/Makefile.am
index 3ecbb5cf0a..d9baf02fe1 100644
--- a/epan/dissectors/Makefile.am
+++ b/epan/dissectors/Makefile.am
@@ -20,7 +20,7 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-noinst_LTLIBRARIES = libdirtydissectors.la libdissectors.la
+noinst_LTLIBRARIES = libdirtydissectors.la libfiledissectors.la libdissectors.la
AM_CPPFLAGS = -I$(srcdir)/../.. -I$(srcdir)/.. \
$(LIBGNUTLS_CFLAGS) $(LIBGCRYPT_CFLAGS)
@@ -36,6 +36,9 @@ if HAVE_WARNINGS_AS_ERRORS
AM_CLEAN_CFLAGS = -Werror
endif
+libfiledissectors_la_SOURCES = \
+ $(FILE_DISSECTOR_SRC)
+
libdissectors_la_SOURCES = \
$(DISSECTOR_SRC) \
$(ASN1_DISSECTOR_SRC) \