aboutsummaryrefslogtreecommitdiffstats
path: root/epan/dissectors/CMakeLists.txt
diff options
context:
space:
mode:
authorDr. Lars Voelker <lars.voelker@bmw.de>2017-04-30 23:31:26 -0400
committerMichael Mann <mmann78@netscape.net>2017-05-05 12:33:38 +0000
commite3d284f6a89b2a04f378d0125cf7a75ec35b76de (patch)
treee292b7b235cb91437817443cc3baa9c253d02d75 /epan/dissectors/CMakeLists.txt
parent4302a0ad650627b4c0e6f48a90ed642939b14841 (diff)
Adding support for the NM protocol.
UDP-NM is an automotive communication protocol as standardized by AUTOSAR and is specified in AUTOSAR_SWS_UDPNetworkManagement.pdf, which can be accessed on: autosar.org -> Classic Platform -> Software Arch -> Comm Stack. It can run over UDP or CAN, which is why "UDP" is not in any user exposed strings. Change-Id: I68adfd941c193588a6c8ef0fe1cb7271f921623e Reviewed-on: https://code.wireshark.org/review/21437 Petri-Dish: Michael Mann <mmann78@netscape.net> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Michael Mann <mmann78@netscape.net>
Diffstat (limited to 'epan/dissectors/CMakeLists.txt')
-rw-r--r--epan/dissectors/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/epan/dissectors/CMakeLists.txt b/epan/dissectors/CMakeLists.txt
index ccbe2d3ba9..c3fa212364 100644
--- a/epan/dissectors/CMakeLists.txt
+++ b/epan/dissectors/CMakeLists.txt
@@ -1296,6 +1296,7 @@ set(DISSECTOR_SRC
packet-ucp.c
packet-udld.c
packet-udp.c
+ packet-udp-nm.c
packet-uds.c
packet-udt.c
packet-uftp.c