aboutsummaryrefslogtreecommitdiffstats
path: root/epan/dissectors/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2017-09-16 21:45:49 -0700
committerMichael Mann <mmann78@netscape.net>2017-09-25 11:48:32 +0000
commit194d30badf547edd9f3f86f2de87322e13a0fa8a (patch)
tree3a975ff5f9822180590c7ab4260d353aabcb0cb0 /epan/dissectors/CMakeLists.txt
parentdc011cc53ebb424ed4fd1383282d929f8688e8e1 (diff)
packet-brcm-tag: Add Broadcom tag dissection
Add support for dissecting the old-style Broadcom tag with Ethertype 0x8874, this was supported by switches like Broadcom BCM5325. Newer switches use a different tag format (with no Ethertype) which will be supported later. Change-Id: Iec26f8d13058399a35fb258ccadc48f7f5ac8474 Reviewed-on: https://code.wireshark.org/review/23592 Petri-Dish: Alexis La Goutte <alexis.lagoutte@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Alexis La Goutte <alexis.lagoutte@gmail.com> Reviewed-by: Michael Mann <mmann78@netscape.net>
Diffstat (limited to 'epan/dissectors/CMakeLists.txt')
-rw-r--r--epan/dissectors/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/epan/dissectors/CMakeLists.txt b/epan/dissectors/CMakeLists.txt
index ce06e363d6..cca5b48c1a 100644
--- a/epan/dissectors/CMakeLists.txt
+++ b/epan/dissectors/CMakeLists.txt
@@ -679,6 +679,7 @@ set(DISSECTOR_SRC
packet-bootparams.c
packet-bpdu.c
packet-bpq.c
+ packet-brcm-tag.c
packet-brdwlk.c
packet-brp.c
packet-bssap.c