aboutsummaryrefslogtreecommitdiffstats
path: root/epan/configure.in
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2003-01-30 10:20:47 +0000
committerJörg Mayer <jmayer@loplof.de>2003-01-30 10:20:47 +0000
commit758685ca0db1f0cf8e50bf30d632372777e68dcb (patch)
tree750329a0be267014ac148110fb221d62578ca135 /epan/configure.in
parent5dc66497b74c45fcd25fe82f34e173585734846d (diff)
AC_ARG_ENABLE takes 4 argument: The 3rd specifies what to do in case a
configure option is given on the command line. The value of the arguement is passwd in the enableval variable. The 4th argument tells what to do in case no command line argument was given. This causes --disable-gtk2 (which is the default) to behave differently from the case when no option is given. I do not really understand where the difference in the behaviour of the generated codes comes from, but I definitely see a difference. Fixed all occurrences where the 3rd arguement was empty. svn path=/trunk/; revision=7044
Diffstat (limited to 'epan/configure.in')
-rw-r--r--epan/configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/epan/configure.in b/epan/configure.in
index b30bcb9ef7..9766dd5eab 100644
--- a/epan/configure.in
+++ b/epan/configure.in
@@ -1,4 +1,4 @@
-# $Id: configure.in,v 1.35 2003/01/21 02:12:37 gerald Exp $
+# $Id: configure.in,v 1.36 2003/01/30 10:20:47 jmayer Exp $
dnl
dnl Process this file with autoconf 2.13 or later to produce a
dnl configure script; 2.12 doesn't generate a "configure" script that
@@ -117,7 +117,7 @@ AC_DEFINE_UNQUOTED(DATAFILE_DIR,"$DATAFILE_DIR")
AC_SUBST(DATAFILE_DIR)
AC_ARG_ENABLE(gtk2,
-[ --enable-gtk2 build Glib2/Gtk2+-based (t)ethereal. [default=no]],enable_gtk2=yes,enable_gtk2=no)
+[ --enable-gtk2 build Glib2/Gtk2+-based (t)ethereal. [default=no]],enable_gtk2=$enableval,enable_gtk2=no)
if test "x$enable_gtk2" = "xyes" ; then
AM_PATH_GLIB_2_0(2.0.0, CFLAGS="$CFLAGS $GLIB_CFLAGS" LIBS="$LIBS $GLIB_LIBS", , gmodule)
@@ -134,7 +134,7 @@ AC_CHECK_HEADERS(arpa/inet.h arpa/nameser.h)
dnl ipv6 check
AC_ARG_ENABLE(ipv6,
-[ --enable-ipv6 use ipv6 name resolution, if available. [default=yes]],,enable_ipv6=yes)
+[ --enable-ipv6 use ipv6 name resolution, if available. [default=yes]],enable_ipv6=$enableval,enable_ipv6=yes)
AC_MSG_CHECKING(whether to enable ipv6 name resolution if available)
if test "x$enable_ipv6" = "xno" ; then