aboutsummaryrefslogtreecommitdiffstats
path: root/epan/configure.in
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2002-03-02 20:51:46 +0000
committerGuy Harris <guy@alum.mit.edu>2002-03-02 20:51:46 +0000
commit52fb615708ad16fdcff9ed92c46791d416a4bdb9 (patch)
tree4bf45b9e83633548134219e06eaffbfacfa08221 /epan/configure.in
parent761ae95b199c474ebe526077a2dbd36044e2701d (diff)
From Joerg Mayer: get rid of "-Wno-unused" flag in some configure
scripts, and check in changes to add _U_ to some unused arguments (some other should perhaps be used, so we leave the _U_ out so that the warnings serve as a reminder to check those). svn path=/trunk/; revision=4848
Diffstat (limited to 'epan/configure.in')
-rw-r--r--epan/configure.in12
1 files changed, 6 insertions, 6 deletions
diff --git a/epan/configure.in b/epan/configure.in
index 4ff6b554eb..61ab5d581d 100644
--- a/epan/configure.in
+++ b/epan/configure.in
@@ -1,4 +1,4 @@
-# $Id: configure.in,v 1.20 2002/02/27 09:42:39 guy Exp $
+# $Id: configure.in,v 1.21 2002/03/02 20:48:10 guy Exp $
dnl
dnl Process this file with autoconf 2.13 or later to produce a
dnl configure script; 2.12 doesn't generate a "configure" script that
@@ -30,16 +30,16 @@ AC_PATH_PROG(LEX, flex)
AC_SUBST(FLEX_PATH)
#
-# If we're running gcc, add '-Wall -W -Wno-unused' to CFLAGS, and add
-# '-D_U_="__attribute__((unused))"' as well, for future use when we
-# remove '-Wno-unused'.
+# If we're running gcc, add '-Wall -W' to CFLAGS, and add
+# '-D_U_="__attribute__((unused))"' as well, so we can use _U_ to
+# flag unused function arguments and not get warnings about them.
#
# Otherwise, add '-D_U_=""', so that _U_ used to flag an unused function
# argument will compile with non-GCC compilers.
#
-AC_MSG_CHECKING(to see if we can add '-Wall -W -Wno-unused' to CFLAGS)
+AC_MSG_CHECKING(to see if we can add '-Wall -W' to CFLAGS)
if test x$GCC != x ; then
- CFLAGS="-D_U_=\"__attribute__((unused))\" -Wall -W -Wno-unused $CFLAGS"
+ CFLAGS="-D_U_=\"__attribute__((unused))\" -Wall -W $CFLAGS"
AC_MSG_RESULT(yes)
else
CFLAGS="-D_U_=\"\" $CFLAGS"