aboutsummaryrefslogtreecommitdiffstats
path: root/epan/Makefile.am
diff options
context:
space:
mode:
authorJoão Valverde <j@v6e.pt>2016-03-03 07:14:34 +0000
committerJoão Valverde <j@v6e.pt>2016-03-03 07:14:53 +0000
commita2371bd6c937e5c3d282849aeb3fba96db1ca356 (patch)
treed750f8c7e62cbff99dba888257baeba112f0ec4a /epan/Makefile.am
parentbfe5e10043c5f31d8360b07bed543a26154eb01c (diff)
Revert "autotools: Use explicit zlib dependency build flags"
This reverts commit 2bded0b66137a2f1c8b69911d91903a24f8a2624. Change-Id: Ic898c65df4daaa395eb010e0286d97509346d43a Reviewed-on: https://code.wireshark.org/review/14318 Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'epan/Makefile.am')
-rw-r--r--epan/Makefile.am9
1 files changed, 4 insertions, 5 deletions
diff --git a/epan/Makefile.am b/epan/Makefile.am
index 9c79ba5468..2daae9e6e4 100644
--- a/epan/Makefile.am
+++ b/epan/Makefile.am
@@ -43,7 +43,7 @@ ACLOCAL_AMFLAGS = `../aclocal-flags`
AM_CPPFLAGS = $(INCLUDEDIRS) -I$(builddir)/wslua $(WS_CPPFLAGS) \
$(GLIB_CFLAGS) $(LUA_CFLAGS) $(LIBGNUTLS_CFLAGS) \
$(LIBGCRYPT_CFLAGS) $(LIBSMI_CFLAGS) $(LIBGEOIP_CFLAGS) \
- $(KRB5_CFLAGS) $(ZLIB_CFLAGS)
+ $(KRB5_CFLAGS)
noinst_LTLIBRARIES = libwireshark_generated.la libwireshark_asmopt.la
lib_LTLIBRARIES = libwireshark.la
@@ -146,7 +146,6 @@ libwireshark_la_LIBADD = \
@LIBSMI_LDFLAGS@ \
@GEOIP_LIBS@ \
@GLIB_LIBS@ \
- $(ZLIB_LIBS) \
-lm
libwireshark_la_DEPENDENCIES = \
@@ -168,17 +167,17 @@ EXTRA_PROGRAMS = reassemble_test tvbtest oids_test
reassemble_test_LDADD = \
libwireshark.la \
$(GLIB_LIBS) \
- $(ZLIB_LIBS)
+ -lz
tvbtest_LDADD = \
libwireshark.la \
$(GLIB_LIBS) \
- $(ZLIB_LIBS)
+ -lz
oids_test_LDADD = \
libwireshark.la \
$(GLIB_LIBS) \
- $(ZLIB_LIBS)
+ -lz
exntest: exntest.o except.o
$(LINK) $^ $(GLIB_LIBS)