aboutsummaryrefslogtreecommitdiffstats
path: root/epan/CMakeLists.txt
diff options
context:
space:
mode:
authorRoland Knall <roland.knall@br-automation.com>2015-03-30 16:10:01 +0200
committerAnders Broman <a.broman58@gmail.com>2015-04-14 04:00:39 +0000
commiteeed4d1121f122aa5579153872193b9a91d8ad52 (patch)
tree671f1f43ba913c80270ee0cc54c7a536009c0cd9 /epan/CMakeLists.txt
parent035d7412892574fcdf6953110cc4e6384602062f (diff)
UI: Implementing menus for plugins
Plugins may utilize the tap interface to provide special tools or analysis options, not otherwise available in Wireshark, or perhaps not allowed to be distributed freely. Up until now, those tools either had to start automatically, or could not be started at all, or had to be started separately. It should be possible, that those tools may be started using a menu entry directly from Wireshark. This interface tries to achieve exactly that. This interface uses a clean interface, which can be implemented in any plugin or dissector. Documentation for this has been added to README.plugins. Separators are only supported for now in the Qt interface, but URLs can now be added as a simple item, and the UI will use the same methods used for other URL calls to open them. Change-Id: I170107dafb66f6badaa864d05a9091e5cbbf52c2 Reviewed-on: https://code.wireshark.org/review/7865 Reviewed-by: Roland Knall <rknall@gmail.com> Petri-Dish: Alexis La Goutte <alexis.lagoutte@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'epan/CMakeLists.txt')
-rw-r--r--epan/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/epan/CMakeLists.txt b/epan/CMakeLists.txt
index d745ec4d0f..0e12b74375 100644
--- a/epan/CMakeLists.txt
+++ b/epan/CMakeLists.txt
@@ -1593,6 +1593,7 @@ set(LIBWIRESHARK_FILES
except.c
expert.c
exported_pdu.c
+ ext_menubar.c
filter_expressions.c
follow.c
frame_data.c