aboutsummaryrefslogtreecommitdiffstats
path: root/epan/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2015-03-07 10:43:45 -0800
committerAnders Broman <a.broman58@gmail.com>2015-03-12 16:37:51 +0000
commitb255d8a1a19cb40a9d04f33e483aa18c3e0a38c8 (patch)
tree41c3f462178e9b8b79860d39fa74ae19d4bfb8b7 /epan/CMakeLists.txt
parentdf164dfc62ae3377057a865a1e4a66119e8a3b2c (diff)
CMake: Update wslua build and test.
Process wslua/CMakeLists.txt using add_subdirectory instead of include. Generate files in the build directory instead of the source directory. Copy lua scripts to DATAFILE_DIR instead of DATAFILE_DIR/lua. That's where init.lua looks for console.lua. Always set WIRESHARK_RUN_FROM_BUILD_DIRECTORY when testing. We presumably want to test our source files and not files which may or may not be in the system path. When we're running from the build directory look for lua scripts in both the Autotools and CMake build locations. Change-Id: Ic15ab8c58ff1b170d000c9b3e0a329af2ec44b7b Reviewed-on: https://code.wireshark.org/review/7590 Reviewed-by: Gerald Combs <gerald@wireshark.org> Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Graham Bloice <graham.bloice@trihedral.com> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'epan/CMakeLists.txt')
-rw-r--r--epan/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/epan/CMakeLists.txt b/epan/CMakeLists.txt
index ad7aaba690..24881aba57 100644
--- a/epan/CMakeLists.txt
+++ b/epan/CMakeLists.txt
@@ -31,7 +31,9 @@ endif()
if (HAVE_LIBLUA)
- include( wslua/CMakeLists.txt )
+ add_subdirectory( wslua )
+ WSLUA_GENERATE_TAP_SRC()
+ WSLUA_GENERATE_REG_SRC()
endif()
source_group(wslua FILES ${WSLUA_FILES})
@@ -43,6 +45,7 @@ include_directories(
${CMAKE_CURRENT_SOURCE_DIR}/dissectors
${CMAKE_CURRENT_SOURCE_DIR}/ftypes
${CMAKE_CURRENT_SOURCE_DIR}/wslua
+ ${CMAKE_CURRENT_BINARY_DIR}/wslua
${CMAKE_CURRENT_SOURCE_DIR}/nghttp2
)