aboutsummaryrefslogtreecommitdiffstats
path: root/epan/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2017-10-26 00:03:09 -0700
committerGuy Harris <guy@alum.mit.edu>2017-10-26 07:03:43 +0000
commit859405fd2dd7b76e00d650e1674db2378e05beff (patch)
tree5398bf88a4ae3290d5412bdb352ccf42da57f8e5 /epan/CMakeLists.txt
parente7abfc397bfa8981b3813c19a64c36cfb275f21d (diff)
Swallow up the stuff from epan/ipv4.c into epan/ftypes/ftype-ipv4.c and epan/ipv4.h.
Most of it doesn't need to be public; pull it into epan/ipv4.c. Pull the two routines that *are* used outside epan/ftypes/ftype-ipv4.c into epan/ipv4.h as static inline functions. This allows some optimization, and makes epan/ipv4.h more like epan/ipv6.h. Change-Id: I80229acde559d810aecec2acd5c995076440c181 Reviewed-on: https://code.wireshark.org/review/24071 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'epan/CMakeLists.txt')
-rw-r--r--epan/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/epan/CMakeLists.txt b/epan/CMakeLists.txt
index a5dcd6a6de..2b1be27c80 100644
--- a/epan/CMakeLists.txt
+++ b/epan/CMakeLists.txt
@@ -238,7 +238,6 @@ set(LIBWIRESHARK_FILES
iana_charsets.c
in_cksum.c
ipproto.c
- ipv4.c
media_params.c
next_tvb.c
oids.c