aboutsummaryrefslogtreecommitdiffstats
path: root/epan/CMakeLists.txt
diff options
context:
space:
mode:
authorJun Wang <sdn_app@163.com>2015-08-22 09:55:31 -0400
committerAnders Broman <a.broman58@gmail.com>2016-02-03 20:59:05 +0000
commit7f3f11f88fc47d0d78780e39907fe92fccefb135 (patch)
treead7ba007df6c27c5fc07e62b07231253a69bc353 /epan/CMakeLists.txt
parent393b1838ad08a1e088f4e11a9adb0681d3ec5fb2 (diff)
Add Userlog dissector
Userlog is user flow logs of H3C device. Flow logging records users' access to the extranet. The device classifies and calculates flows through the 5-tuple information, which includes source IP address, destination IP address, source port, destination port, and protocol number, and generates user flow logs. Flow logging records the 5-tuple information of the packets and number of the bytes received and sent. With flow logs, administrators can track and record accesses to the network, facilitating the availability and security of the network. examplecapture: https://wiki.wireshark.org/SampleCaptures#UserLog Bug: 11878 Change-Id: If3b5ca75bdd6cd8dc12af4a35401c5a6aa193a73 Reviewed-on: https://code.wireshark.org/review/8148 Reviewed-by: Michael Mann <mmann78@netscape.net> Petri-Dish: Michael Mann <mmann78@netscape.net> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'epan/CMakeLists.txt')
-rw-r--r--epan/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/epan/CMakeLists.txt b/epan/CMakeLists.txt
index 15ea2578ef..e53db404f8 100644
--- a/epan/CMakeLists.txt
+++ b/epan/CMakeLists.txt
@@ -1383,6 +1383,7 @@ set(DISSECTOR_SRC
dissectors/packet-usb-video.c
dissectors/packet-usb.c
dissectors/packet-user_encap.c
+ dissectors/packet-userlog.c
dissectors/packet-uts.c
dissectors/packet-v120.c
dissectors/packet-v150fw.c