aboutsummaryrefslogtreecommitdiffstats
path: root/epan/CMakeLists.txt
diff options
context:
space:
mode:
authorStig Bjørlykke <stig@bjorlykke.org>2011-08-31 09:00:54 +0000
committerStig Bjørlykke <stig@bjorlykke.org>2011-08-31 09:00:54 +0000
commit5359494b1f7fbfa4fce2e98e4d9e579a0fdafff4 (patch)
tree8d6f30d58eeb9b379d0db577f7f5d9e975a1d149 /epan/CMakeLists.txt
parent48221f4dfda01b750f5d00548d8c37a578d3a53b (diff)
Second try to move crc routines to libwsutil.
This time keep the tvb routines in epan. Now we can use common crc routines outside epan. svn path=/trunk/; revision=38810
Diffstat (limited to 'epan/CMakeLists.txt')
-rw-r--r--epan/CMakeLists.txt15
1 files changed, 3 insertions, 12 deletions
diff --git a/epan/CMakeLists.txt b/epan/CMakeLists.txt
index bbcad3ab23..86b78341f0 100644
--- a/epan/CMakeLists.txt
+++ b/epan/CMakeLists.txt
@@ -39,10 +39,6 @@ include_directories(
${CMAKE_CURRENT_SOURCE_DIR}/wspython
)
-set(CRC_FILES
- crc/crc-16-plain.c
-)
-
set(CRYPT_FILES
crypt/airpdcap.c
crypt/airpdcap_ccmp.c
@@ -1209,12 +1205,9 @@ set(LIBWIRESHARK_FILES
column.c
column-utils.c
conversation.c
- crc10.c
- crc16.c
- crc32.c
- crc6.c
- crc8.c
- crcdrm.c
+ crc16-tvb.c
+ crc32-tvb.c
+ crc8-tvb.c
dissector_filters.c
emem.c
epan.c
@@ -1310,7 +1303,6 @@ set(CLEAN_FILES
#x11-declarations.h
#x11-register-info.h
${LIBWIRESHARK_CLEAN_FILES}
- ${CRC_FILES}
${CRYPT_FILES}
${DFILTER_CLEAN_FILES}
${FTYPE_FILES}
@@ -1339,7 +1331,6 @@ add_library(epan ${LINK_MODE_LIB}
#x11-declarations.h
#x11-register-info.h
${LIBWIRESHARK_FILES}
- ${CRC_FILES}
${CRYPT_FILES}
${DFILTER_FILES}
${FTYPE_FILES}