aboutsummaryrefslogtreecommitdiffstats
path: root/epan/CMakeLists.txt
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss@ulticom.com>2011-05-26 01:55:04 +0000
committerJeff Morriss <jeff.morriss@ulticom.com>2011-05-26 01:55:04 +0000
commit28bae657ae2c524503374b9fffc4f945ace09952 (patch)
tree3bdb017843bf40e4ad547121a3d904d37ecdd422 /epan/CMakeLists.txt
parent8f5742c5ad0fd2d5456d6683e4f6c9b324c5c34c (diff)
From Florian Fainelli via https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=5943 :
The two patches attached allow the dissection of the Homeplug AV Ethernet MAC management frames between a controlling device and a Homeplug AV Ethernet to PLC adapter. This protocol is pretty similar to the previous generation Homeplug protocol (dissected by packet-homeplug.c) but a couple of noticeable differences make it require its own dissector handler. This dissector is based on the work done by Nicolas Thill, Xavier Carcelle and myself in the Faifa project (https://dev.open-plc.org). The dissector handles the standard Homeplug AV Ethernet MAC management frames (called public) as well as the Intellon specific management frames (vendor). From me: Remove unnecessary global variables. Add to COL_INFO even when !tree. Remove gotos. Remove unnecessary includes. svn path=/trunk/; revision=37403
Diffstat (limited to 'epan/CMakeLists.txt')
-rw-r--r--epan/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/epan/CMakeLists.txt b/epan/CMakeLists.txt
index bff63f4785..a71793a2da 100644
--- a/epan/CMakeLists.txt
+++ b/epan/CMakeLists.txt
@@ -625,6 +625,7 @@ set(DISSECTOR_SRC
dissectors/packet-hilscher.c
dissectors/packet-hip.c
dissectors/packet-homeplug.c
+ dissectors/packet-homeplug-av.c
dissectors/packet-hp-erm.c
dissectors/packet-hpext.c
dissectors/packet-hpsw.c