aboutsummaryrefslogtreecommitdiffstats
path: root/docbook/Makefile.am
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2013-07-29 21:12:05 +0000
committerGerald Combs <gerald@wireshark.org>2013-07-29 21:12:05 +0000
commit58ee866ec8663b9d8253a89841fdc819e0ad3f34 (patch)
treeb1bf74e96831f436ffef10758344ff275d44095d /docbook/Makefile.am
parent3b92f760ed9c4b699cb8968f1a690e31cfec182a (diff)
Name our index pages "index.html". This is follows a well-established
convention and lets us avoid a bit of juggling on the server side. svn path=/trunk/; revision=51021
Diffstat (limited to 'docbook/Makefile.am')
-rw-r--r--docbook/Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/docbook/Makefile.am b/docbook/Makefile.am
index d0afb1a8de..d3bcdb3734 100644
--- a/docbook/Makefile.am
+++ b/docbook/Makefile.am
@@ -96,9 +96,9 @@ else
endif
# create html single page file
-user-guide.html: wsug_html/user-guide.html
+user-guide.html: wsug_html/index.html
-wsug_html/user-guide.html: $(WSUG_SOURCE) wsluarm
+wsug_html/index.html: $(WSUG_SOURCE) wsluarm
@ echo --- WSUG - HTML SINGLE PAGE ---
mkdir -p wsug_html/wsug_graphics/toolbar
cp $(srcdir)/wsug_graphics/*.* wsug_html/wsug_graphics
@@ -147,9 +147,9 @@ wsluarm: make-wsluarm.pl $(WSLUA_MODULES)
# Wireshark Developer Guide
if HAVE_FOP
-WSDG_TARGETS=wsdg.validated wsdg_html_chunked developer-guide.html developer-guide-a4.pdf developer-guide-us.pdf
+WSDG_TARGETS=wsdg.validated wsdg_html_chunked wsdg_html developer-guide-a4.pdf developer-guide-us.pdf
else
-WSDG_TARGETS=wsdg.validated wsdg_html_chunked developer-guide.html
+WSDG_TARGETS=wsdg.validated wsdg_html_chunked wsdg_html
endif
wsdg: $(WSDG_TARGETS)
@@ -165,9 +165,9 @@ else
endif
# create html single page file
-developer-guide.html: wsdg_html/developer-guide.html
+wsdg_html: wsdg_html/index.html
-wsdg_html/developer-guide.html: $(WSDG_SOURCE)
+wsdg_html/index.html: $(WSDG_SOURCE)
@ echo --- WSDG - HTML SINGLE PAGE ---
mkdir -p wsdg_html/wsdg_graphics/toolbar
cp $(srcdir)/wsdg_graphics/*.* wsdg_html/wsdg_graphics