aboutsummaryrefslogtreecommitdiffstats
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorPascal Quantin <pascal.quantin@gmail.com>2015-11-24 23:03:13 +0100
committerAnders Broman <a.broman58@gmail.com>2016-04-25 07:22:28 +0000
commitae316e2d888e3204f08593c27b4c2360eff7f679 (patch)
tree26baec1e2daaee3578b4ae8450831703c47c877a /doc/Makefile.am
parentc3574ed4173917f6ad89f40ab0b0dc0b1ad5e62d (diff)
Compile sshdump and ciscodump for Windows
Use libSSH 0.7.2 compiled with MinGW(32|64) and linked with zlib and gcrypt support Change-Id: I7c17d1ba3dd1890e2f83c119f5ea851834807e43 Reviewed-on: https://code.wireshark.org/review/12117 Petri-Dish: Pascal Quantin <pascal.quantin@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 4d69a91a48..6a2004b2d9 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -86,7 +86,7 @@ man_MANS =
noinst_DATA = asn2deb.1 asn2deb.html idl2deb.1 idl2deb.html idl2wrs.1 idl2wrs.html
pkgdata_DATA = AUTHORS-SHORT $(top_srcdir)/docbook/ws.css wireshark.html \
- tshark.html wireshark-filter.html capinfos.html editcap.html \
+ tshark.html wireshark-filter.html capinfos.html ciscodump.html editcap.html \
mergecap.html reordercap.html text2pcap.html dumpcap.html androiddump.html \
sshdump.html randpktdump.html rawshark.html dftest.html randpkt.html \
extcap.html
@@ -237,6 +237,13 @@ sshdump.html: sshdump.pod ../config.h $(top_srcdir)/docbook/ws.css
--noindex \
$(srcdir)/sshdump.pod > sshdump.html
+ciscodump.html: ciscodump.pod ../config.h $(top_srcdir)/docbook/ws.css
+ $(AM_V_POD2HTML)$(POD2HTML) \
+ --title="ciscodump - The Wireshark Network Analyzer $(VERSION)" \
+ --css=$(POD_CSS_URL) \
+ --noindex \
+ $(srcdir)/ciscodump.pod > ciscodump.html
+
randpktdump.html: randpktdump.pod ../config.h $(top_srcdir)/docbook/ws.css
$(AM_V_POD2HTML)$(POD2HTML) \
--title="randpktdump - The Wireshark Network Analyzer $(VERSION)" \
@@ -307,6 +314,7 @@ EXTRA_DIST = \
asn2deb.pod \
capinfos.pod \
captype.pod \
+ ciscodump.pod \
dfilter2pod.pl \
dftest.pod \
dumpcap.pod \
@@ -326,7 +334,7 @@ EXTRA_DIST = \
rawshark.pod \
reordercap.pod \
sgml.doc.template \
- sshdump.pod \
+ sshdump.pod \
text2pcap.pod \
tshark.pod \
wireshark-filter.pod \