aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2018-04-30 14:42:29 -0700
committerGerald Combs <gerald@wireshark.org>2018-04-30 22:38:37 +0000
commited384882117696d4ff110e46bc60ebe9ac304974 (patch)
treeff95e5772929b3af0400b8742d808bbc711da7f7 /debian/rules
parentbd5a7d029537a2eea0ae723e3dbe3d191144eb54 (diff)
Test: Add unittests.
Note that these require the "test-programs" target. Change-Id: I1bea381eaa48504fcd76f88e1c6f2edece0a78a2 Reviewed-on: https://code.wireshark.org/review/27231 Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 4 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index ced9cb339d..9add94da3d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -35,6 +35,10 @@ override_dh_auto_build:
$(MAKE) -C $(CURDIR)/obj-* user_guide_html developer_guide_html
# fix links in documentation
sed -i "s|$(CURDIR)/docbook|..|" obj-*/docbook/ws*g_html_chunked/*.html
+ifneq ($(filter $(DEB_BUILD_OPTIONS),nocheck),)
+ # Required for the "unittests" suite.
+ $(MAKE) -C $(CURDIR)/obj-* test-programs
+endif
override_dh_strip:
dh_strip --dbg-package=wireshark-dbg