aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2011-08-18 20:38:25 +0000
committerJörg Mayer <jmayer@loplof.de>2011-08-18 20:38:25 +0000
commitaa22951fa8d52a4773b54304b1da70b04d1399ad (patch)
tree277e1bdcd9796a540975188365077980af4d82c1 /configure.in
parentdd7d285d0fd99e028900453b5c2e146cfbf23d54 (diff)
When building with GTK3 we *must* use the ui-manager interface,
the ItemFactory stuff doesn't exists any more. svn path=/trunk/; revision=38607
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 8 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index 95f5119f42..74019c33e8 100644
--- a/configure.in
+++ b/configure.in
@@ -738,14 +738,6 @@ AC_ARG_ENABLE(wireshark,
[build GTK+-based Wireshark @<:@default=yes, if GTK+ available@:>@]),
enable_wireshark=$enableval,enable_wireshark=yes)
-AC_ARG_ENABLE(ui-manager,
- AC_HELP_STRING( [--enable-ui-manager],
- [use ui-manager in Wireshark (experimental) @<:@default=no@:>@]),
- enable_uimanager=$enableval,enable_uimanager=no)
-if test x$enable_uimanager = xyes; then
- AC_DEFINE(MAIN_MENU_USE_UIMANAGER, 1, [Use GTK ui-manager])
-fi
-
AC_ARG_ENABLE(packet-editor,
AC_HELP_STRING( [--enable-packet-editor],
[add support for packet editor in Wireshark @<:@default=no@:>@]),
@@ -828,6 +820,14 @@ else
GTK_OK=no
fi
+AC_ARG_ENABLE(ui-manager,
+ AC_HELP_STRING( [--enable-ui-manager],
+ [use ui-manager in Wireshark (experimental) @<:@default=no@:>@]),
+ enable_uimanager=$enableval,enable_uimanager=no)
+if test x$enable_uimanager = xyes or x$with_gtk3= "xyes"; then
+ AC_DEFINE(MAIN_MENU_USE_UIMANAGER, 1, [Use GTK ui-manager])
+fi
+
# GLib checks; we require GLib 2.14 or later, and require gmodule
# support, as we need that for dynamically loading plugins.
# If we found GTK+, this doesn't add GLIB_CFLAGS to CFLAGS, because