aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBill Meier <wmeier@newsguy.com>2011-08-11 02:08:30 +0000
committerBill Meier <wmeier@newsguy.com>2011-08-11 02:08:30 +0000
commita5abe51580cbe0e88369002c7d82670bce88b573 (patch)
treeb65d67c4952feeea17776360eb3ea5015a334bc7 /configure.in
parentfda7fc7ca682b016a3b7579a7865ce782560d7d6 (diff)
Add -DG_DISABLE_SINGLE_INCLUDES to CFLAGS
Also: Move the addition of -DG_DISABLE_DEPRECATED to CFLAGS so that it actually takes effect. svn path=/trunk/; revision=38466
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index d59ff6f7d2..857ac63a49 100644
--- a/configure.in
+++ b/configure.in
@@ -880,6 +880,14 @@ else
fi
fi
+# Error out if a glib header other than a "top level" header
+# (glib.h, glib-object.h, gio.h) or certain other headers( e.g.,gmodule.h)
+# is used.
+CFLAGS="-DG_DISABLE_SINGLE_INCLUDES $CFLAGS"
+
+# Error out on the usage of deprecated glib functions
+CFLAGS="-DG_DISABLE_DEPRECATED $CFLAGS"
+
#
# Check whether GLib modules are supported, to determine whether we
# can support plugins.
@@ -888,8 +896,6 @@ AC_MSG_CHECKING(whether GLib supports loadable modules)
ac_save_CFLAGS="$CFLAGS"
ac_save_LIBS="$LIBS"
CFLAGS="$CFLAGS $GLIB_CFLAGS"
-# Error out on the usage of deprecated glib functions
-CFLAGS="$CFLAGS -DG_DISABLE_DEPRECATED"
LIBS="$GLIB_LIBS $LIBS"
AC_TRY_RUN([
#include <glib.h>