aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2011-07-18 12:49:16 +0000
committerJörg Mayer <jmayer@loplof.de>2011-07-18 12:49:16 +0000
commit9a7fcb7ec776135937658cc5a1fce4fd89167897 (patch)
tree526c5853604245e0ba6f344cabdcafc9b98ef462 /configure.in
parent6dace0449383937167c4744c489eefc541a62b57 (diff)
Add option --enable-uimanager to mimic cmake -DUI_MANAGER=ON
svn path=/trunk/; revision=38081
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 2cdacec420..19470e5142 100644
--- a/configure.in
+++ b/configure.in
@@ -730,6 +730,18 @@ AC_ARG_ENABLE(wireshark,
AC_HELP_STRING( [--enable-wireshark],
[build GTK+-based wireshark. @<:@default=yes, if GTK+ available@:>@]),
enable_wireshark=$enableval,enable_wireshark=yes)
+if test x$enable_wireshark = xyes; then
+ CFLAGS="-DGTK_DISABLE_SINGLE_INCLUDES $CFLAGS"
+fi
+
+AC_ARG_ENABLE(ui_manager,
+ AC_HELP_STRING( [--enable-uimanager],
+ [use ui-manager in Wireshark (experimental). @<:@default=no@:>@]),
+ enable_uimanager=$enableval,enable_uimanager=no)
+if test x$enable_uimanager = xyes; then
+ AC_DEFINE(UI_MANAGER, 1, [Use gtk ui-manager])
+ CFLAGS="-DGTK_DISABLE_DEPRECATED $CFLAGS"
+fi
AC_ARG_ENABLE(packet-editor,
AC_HELP_STRING( [--enable-packet-editor],