aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2008-03-15 18:31:52 +0000
committerGerald Combs <gerald@wireshark.org>2008-03-15 18:31:52 +0000
commit46bcad885a7a0c8e7d9b0009b0e231cb3c3677e9 (patch)
treeda6234e8eb1c99e0c4c0bc9f7dbfa6eb303f12fe /configure.in
parentdca49accfae6990c6a1dcef28c09104adc82828d (diff)
Check in the OS X packaging patch from bug 2341, since I've had
confirmation that the OS X package works on at least one system other than my laptop. svn path=/trunk/; revision=24640
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index de8e5f82c1..3b5c19ac0d 100644
--- a/configure.in
+++ b/configure.in
@@ -166,6 +166,8 @@ AM_CONDITIONAL(HAVE_HHC, test x$HAVE_HHC = xyes)
# Check for packaging utilities
# For now, we check to see if the various packaging utilites are in our
# path. I'm too lazy to write code to go hunt for them. - Gerald
+
+# SVR4/Solaris
AC_CHECK_PROG(HAVE_PKGPROTO, pkgproto, "yes", "no")
AC_CHECK_PROG(HAVE_PKGMK, pkgmk, "yes", "no")
AC_CHECK_PROG(HAVE_PKGTRANS, pkgtrans, "yes", "no")
@@ -178,9 +180,26 @@ else
fi
AC_SUBST(HAVE_SVR4_PACKAGING)
+# RPM
AC_WIRESHARK_RPM_CHECK
AC_SUBST(HAVE_RPM)
+# Debian
+AC_CHECK_PROG(HAVE_DPKG_BUILDPACKAGE, dpkg-buildpackage, "yes", "no")
+
+# Mac OS X
+AC_CHECK_PROG(HAVE_XCODEBUILD, xcodebuild, "yes", "no")
+AC_CHECK_PROG(HAVE_HDIUTIL, hdiutil, "yes", "no")
+AC_CHECK_PROG(HAVE_BLESS, bless, "yes", "no")
+
+if test x$HAVE_XCODEBUILD = xyes -a x$HAVE_HDIUTIL = xyes \
+ -a x$HAVE_BLESS = xyes ; then
+ HAVE_OSX_PACKAGING=yes
+else
+ HAVE_OSX_PACKAGING=no
+fi
+AC_SUBST(HAVE_OSX_PACKAGING)
+
#
# Try to add some additional gcc checks to CFLAGS
#
@@ -1668,6 +1687,7 @@ AC_OUTPUT(
gtk/doxygen.cfg
help/Makefile
packaging/Makefile
+ packaging/macosx/Info.plist
packaging/nsis/Makefile
packaging/rpm/Makefile
packaging/rpm/SPECS/Makefile