aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-02-19 16:57:39 +0000
committerJoão Valverde <j@v6e.pt>2016-02-19 21:47:04 +0000
commiteb9d2b00922c109c932eb339b2b2c92f04df06dd (patch)
tree7051b55e734dec18eb1f572e6d45a90cd20ea4cc /configure.ac
parent472687b5e1554fd0b7051eb2ee17ca03b9e6211c (diff)
Fix implicit conversion from 64 to 32 bits
Change size_t to something that is guaranteed to fit in a socklen_t. Fix incorrect AC_DEFINE too. Change-Id: I710f32fb1e5bd4f51843d380aa8ed8b6acd98c02 Reviewed-on: https://code.wireshark.org/review/14009 Petri-Dish: Alexis La Goutte <alexis.lagoutte@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 759e7e52b3..1ab3d29c4d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2945,7 +2945,7 @@ have_inet_pton=no)
if test "$have_inet_pton" = no; then
INET_PTON_LO="inet_pton.lo"
else
- AC_DEFINE(HAVE_INET_NTOP, 1,
+ AC_DEFINE(HAVE_INET_PTON, 1,
[Define to 1 if you have the `inet_pton' function.])
INET_PTON_LO=""
fi