aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDario Lombardo <lomato@gmail.com>2015-11-25 16:35:14 +0100
committerAnders Broman <a.broman58@gmail.com>2015-11-27 08:02:41 +0000
commitbec2fc09540ee3c45c6a2483a1cdbc1bb63fb934 (patch)
treeb2a829b24f44f5bca7f2a34c4b9964ffb37f90eb /configure.ac
parentfaf680fbd4c129679b94f78bf76a9e1b955a5729 (diff)
sshdump: move build check
Check was made too early, when libssh was still unchecked. Change-Id: I6c84548b48e99d277f67f3a7ea06b4e759111034 Reviewed-on: https://code.wireshark.org/review/12141 Petri-Dish: Anders Broman <a.broman58@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac34
1 files changed, 17 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index b6dea53374..7a31fc71cf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2351,23 +2351,6 @@ else
AC_MSG_RESULT(no)
fi
-if test "x$enable_sshdump" = "xyes" ; then
- if test "x$have_good_libssh" = "xyes" ; then
- sshdump_bin="sshdump\$(EXEEXT)"
- sshdump_man="sshdump.1"
- else
- echo "Can't find libssh. Disabling sshdump."
- enable_sshdump=no
- sshdump_bin=""
- sshdump_man=""
- fi
-else
- sshdump_bin=""
- sshdump_man=""
-fi
-AC_SUBST(sshdump_bin)
-AC_SUBST(sshdump_man)
-
# Enable/disable echld
AC_ARG_ENABLE(echld,
AC_HELP_STRING( [--enable-echld],
@@ -3093,6 +3076,23 @@ then
fi
AC_SUBST(extcapdir)
+if test "x$enable_sshdump" = "xyes" ; then
+ if test "x$have_good_libssh" = "xyes" ; then
+ sshdump_bin="sshdump\$(EXEEXT)"
+ sshdump_man="sshdump.1"
+ else
+ echo "Can't find libssh. Disabling sshdump."
+ enable_sshdump=no
+ sshdump_bin=""
+ sshdump_man=""
+ fi
+else
+ sshdump_bin=""
+ sshdump_man=""
+fi
+AC_SUBST(sshdump_bin)
+AC_SUBST(sshdump_man)
+
dnl libtool defs
#
# Yes, AM_PROG_LIBTOOL is redundant with newer version(s) of some tool(s)