aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2017-10-14 20:11:24 +0100
committerMichael Mann <mmann78@netscape.net>2017-10-22 13:10:50 +0000
commitaa04d2355effb1cf611831b0a260cf1aff199b9a (patch)
treef9283f8970773a6243ceb9d534b1c31d8be7bc08 /configure.ac
parentb0432442c607c7d71e40c55ffd0bf46f43ef3d1a (diff)
autotools: Build and install user guide
Installs the WSUG to $docdir, unless the --disable-guides option is given to the configure script. This will open the Help->Contents menu action using the locally installed guide. It will also point to the correct version for this Wireshark release. The wireshark.org link only provides the guide for the master branch. Change-Id: I9dd539c737cb3777dc1351707b9e45a3a6764aaa Reviewed-on: https://code.wireshark.org/review/23906 Petri-Dish: João Valverde <j@v6e.pt> Reviewed-by: João Valverde <j@v6e.pt> Tested-by: João Valverde <j@v6e.pt> Reviewed-by: Michael Mann <mmann78@netscape.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac37
1 files changed, 34 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 1708d92046..da96de3623 100644
--- a/configure.ac
+++ b/configure.ac
@@ -437,11 +437,35 @@ esac
AX_LIBSMI
#
+# Check if we should build the Wireshark User's Guide
+#
+AC_ARG_ENABLE(guides,
+ AC_HELP_STRING( [--disable-guides],
+ [Don't build the Wireshark User's Guide]),
+ [want_wsug=$enableval], [want_wsug=if_available])
+
+#
# Check for programs used when building DocBook documentation.
#
-AC_CHECK_PROGS(XSLTPROC, xsltproc, xsltproc)
-AC_CHECK_PROGS(A2X, a2x, a2x)
-AC_CHECK_PROGS(FOP, fop, fop)
+have_wsug=yes
+AC_PATH_PROG(XSLTPROC, xsltproc, xsltproc)
+AS_IF([test ! -x "$XSLTPROC"],
+ [
+ AS_IF([test "x$want_wsug" = xyes],
+ [AC_MSG_ERROR([xlstproc not found but required to build the Wireshark User's Guide])])
+ have_wsug=no
+ ])
+AC_PATH_PROG(A2X, a2x, a2x)
+AS_IF([test ! -x "$A2X"],
+ [
+ AS_IF([test "x$want_wsug" = xyes],
+ [AC_MSG_ERROR([a2x not found but required to build the Wireshark User's Guide])])
+ have_wsug=no
+ ])
+
+AC_PATH_PROG(FOP, fop, fop)
+
+AM_CONDITIONAL(BUILD_USER_GUIDE, [test "x$have_wsug" = xyes -a "x$want_wsug" != xno])
# HTML to text processor
AC_MSG_CHECKING([for an HTML to text processor])
@@ -3101,6 +3125,12 @@ else
bcg729_message="no"
fi
+if test "x$have_wsug" = xyes -a "x$want_wsug" != xno; then
+ wsug_message="yes"
+else
+ wsug_message="no"
+fi
+
echo ""
echo " CPPFLAGS: $WS_CPPFLAGS $CPPFLAGS"
echo ""
@@ -3135,6 +3165,7 @@ echo " Build sshdump : $enable_sshdump"
echo " Build ciscodump : $enable_ciscodump"
echo " Build randpktdump : $enable_randpktdump"
echo " Build udpdump : $enable_udpdump"
+echo " Build User's Guide : $wsug_message"
echo ""
echo " Save files as pcap-ng by default : $enable_pcap_ng_default"
echo " Install dumpcap with capabilities : $setcap_message"