aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2014-08-03 03:40:11 -0700
committerGuy Harris <guy@alum.mit.edu>2014-08-03 10:41:19 +0000
commit7df03a7c3ec4c89a3f623d00f828bc66ce120ddc (patch)
tree244d52cd9b9ae73f4e927f3f85574973b97fb09d /configure.ac
parent8d51a50a819b293d5bfb95238b9fb11d8789b988 (diff)
Get rid of debugging output, and get CMake to produce verbose makefiles.
On the 32-bit OS X buildbot, automake is old enough that autotools builds are verbose, printing the command line for each compile step; if we cause CMake to produce verbose makefiles, they will also print the command line, so we can see what differences there are. This means the other debugging output we added isn't necessary; remove it. Sort the extra warning options in configure.ac based on whether they're for C and C++ or just C, just as is the case in CMake, to make it easier to keep the lists in sync; add comments to configure.ac to mirror the ones in CMakeLists.txt. Get rid of -Wno-deprecated-declarations; the CMake build doesn't use it, and it doesn't appear to be necessary - if we ever have problems with OS X complaining about using OpenSSL, for example, we should do as tcpdump does and wrap uses of the "deprecated"-but-cross-platform APIs in the appropriate pragmas. Change-Id: I0b8b45f00481ac2b67da5c7dd028a029b130dcc4 Reviewed-on: https://code.wireshark.org/review/3377 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac43
1 files changed, 19 insertions, 24 deletions
diff --git a/configure.ac b/configure.ac
index dcacc6058d..d226cbc97d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -757,6 +757,9 @@ AC_ARG_ENABLE(extra-compiler-warnings,
wireshark_extra_flags=$enableval
if test $enableval != no
then
+ #
+ # The following are for C and C++
+ #
AC_WIRESHARK_COMPILER_FLAGS_CHECK(-pedantic)
#
# Various code blocks this one.
@@ -766,10 +769,9 @@ AC_ARG_ENABLE(extra-compiler-warnings,
#
# Due to various places where APIs we don't control
# require us to cast away constness, we can probably
- # never enable these ones with -Werror.
+ # never enable this one with -Werror.
#
AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wcast-qual)
- AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wbad-function-cast, C)
#
# Some generated ASN.1 dissectors block this one;
# multiple function declarations for the same
@@ -800,9 +802,21 @@ AC_ARG_ENABLE(extra-compiler-warnings,
# (about glib library not using Doxygen)
#
AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wdocumentation)
+
+ #
+ # The following are C only, not C++
+ #
+ # Due to various places where APIs we don't control
+ # require us to cast away constness, we can probably
+ # never enable this one with -Werror.
+ #
+ AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wbad-function-cast, C)
fi
],)
+#
+# The following are for C and C++
+#
AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wall -W) # -W is now known as -Wextra
AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wextra) # -W is now known as -Wextra
AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wendif-labels)
@@ -823,6 +837,9 @@ AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wwrite-strings)
AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wno-long-long)
AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wheader-guard)
+#
+# The following are C only, not C++
+#
AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wc++-compat, C)
AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wdeclaration-after-statement, C)
@@ -887,20 +904,6 @@ AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wjump-misses-init, C)
AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wshorten-64-to-32, C)
#
-# On OS X, suppress warnings about deprecated declarations, because
-# they apparently think everything on OS X is Shiny Happy Apple-
-# Framework-Based Apps and are deprecating some perfectly OK
-# multi-platform open-source libraries that we use in our multi-platform
-# open-source application in favor of various frameworks that are
-# OS X-only.
-#
-case "$host_os" in
-darwin*)
-# AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wno-deprecated-declarations)
- ;;
-esac
-
-#
# Use the faster pre gcc 4.5 floating point precision if available.
#
AC_WIRESHARK_COMPILER_FLAGS_CHECK(-fexcess-precision=fast)
@@ -3076,11 +3079,3 @@ echo " Use POSIX capabilities library : $libcap_message"
echo " Use GeoIP library : $geoip_message"
echo " Use nl library : $libnl_message"
echo " Use SBC codec library : $have_sbc"
-#
-# Debugging differences between autotools and CMake builds; dump
-# CC, CXX, CFLAGS, and CXXFLAGS.
-#
-echo " CC : $CC"
-echo " CFLAGS : $CFLAGS"
-echo " CXX : $CXX"
-echo " CXXFLAGS : $CXXFLAGS"