aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-04-13 21:47:23 +0100
committerJoão Valverde <j@v6e.pt>2016-04-13 20:54:36 +0000
commit6f034b3a5e753a6ddb88a6179988a4626bed8630 (patch)
treeb5ca8008557650ebb0fd549e5ce1cd74b7a6897e /configure.ac
parentd77029d55dc5e3b5daa6c161deb098e786184afa (diff)
Fix configure script
Do not use default ACTION_IF_NOT_FOUND. Fixes bug in d77029d55dc5e3b5daa6c161deb098e786184afa. Change-Id: Ia6d27015ef51add19e5457bdf035e08a6c444a43 Reviewed-on: https://code.wireshark.org/review/14906 Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5635d90bc6..cebff0354f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1646,6 +1646,9 @@ if test "x$enable_wireshark" = "xyes"; then
have_gtk=yes
GTK_VERSION=`$PKG_CONFIG --modversion gtk+-3.0`
GUI_CONFIGURE_FLAGS="$GUI_CONFIGURE_FLAGS --with-gtk=3"
+ ],
+ [
+ :
])],
[2], [PKG_WIRESHARK_CHECK_SYSTEM_MODULES([GTK],
[gtk+-2.0 >= $GTK2_MIN_VERSION glib-2.0 >= $GLIB_MIN_VERSION gthread-2.0 >= $GLIB_MIN_VERSION gmodule-2.0 >= $GLIB_MIN_VERSION],
@@ -1653,6 +1656,9 @@ if test "x$enable_wireshark" = "xyes"; then
have_gtk=yes
GTK_VERSION=`$PKG_CONFIG --modversion gtk+-2.0`
GUI_CONFIGURE_FLAGS="$GUI_CONFIGURE_FLAGS --with-gtk=2"
+ ],
+ [
+ :
])],
[fail3], [AC_MSG_ERROR([GTK+ 3 was requested but is not available])],
[fail2], [AC_MSG_ERROR([GTK+ 2 was requested but is not available])],