aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-03-28 09:07:12 +0100
committerJoão Valverde <j@v6e.pt>2016-03-29 14:05:48 +0000
commit26f3a9aa844924fe4a7d89982d3c4b0dce440a7c (patch)
tree0e10851b8aac1fabb9f1281103dba6838e37c626 /configure.ac
parentc436452769d7751d2afd347a4953b4628be17836 (diff)
Use "old-style" moc options to ensure backward compatibility for Qt tools
Change-Id: Ic96df4ba521e0fbaf4ac34f23e3a89304ed5de5c Reviewed-on: https://code.wireshark.org/review/14662 Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 08424d9766..d44706ff2c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1704,11 +1704,13 @@ if test "x$enable_wireshark" = "xyes"; then
;;
esac
AC_SUBST(Qt_LDFLAGS)
- if test -z "$MOC_OPTIONS"
+
+ if test -z "${MOC_OPTIONS+1}"
then
if test $qt_version -eq 5
then
- MOC_OPTIONS="--no-notes"
+ # Squelch moc verbose "nothing to do" output
+ MOC_OPTIONS="-nn"
elif test $qt_version -eq 4
then
qt_minor_version=`echo "$QT_VERSION" | cut -f2 -d.`