aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2015-12-14 14:06:14 -0800
committerGuy Harris <guy@alum.mit.edu>2015-12-14 22:07:53 +0000
commit2036ffd72b4254e67223016ac234cdd9cb6bbca6 (patch)
treeb3e1065b577057d6b121e4bc95acbb17e38c6e8d /configure.ac
parent39cc323722b0aee95cad3febee628737dc7981cb (diff)
Note why we do -Wno-variadic-macros.
Change-Id: Icaa5c1e927d0984bd76d9d157166de359891d381 Reviewed-on: https://code.wireshark.org/review/12638 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1427a6e79c..a7cb6c30af 100644
--- a/configure.ac
+++ b/configure.ac
@@ -872,6 +872,10 @@ AC_ARG_ENABLE(extra-compiler-warnings,
# The following are for C and C++
#
AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wpedantic)
+ #
+ # As we use variadic macros, we don't want warnings
+ # about them, even with -Wpedantic.
+ #
AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wno-variadic-macros)
#
# Various code blocks this one.