aboutsummaryrefslogtreecommitdiffstats
path: root/caputils/Makefile.am
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2015-11-27 02:28:17 +0000
committerJoão Valverde <j@v6e.pt>2016-01-28 18:13:48 +0000
commit265a41e14da6b3ebf1e49e726eee62d1372110bf (patch)
treef1a524f8e66ebd43691de84649f231f32ee125f6 /caputils/Makefile.am
parent97a1a50e200a6c50e0014dde7e8ec932c30190a1 (diff)
autotools: Don't use "user variables" to set build flags
GNU coding standards recommend against it and automake is designed around it. This allows overriding the global build flags using AM_CFLAGS, etc., or per object flags, something that is difficult or impossible currently because of automake precedence rules. Change-Id: I3f1ea12e560af5a46b2f04b342b1882bbf123f12 Reviewed-on: https://code.wireshark.org/review/13455 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'caputils/Makefile.am')
-rw-r--r--caputils/Makefile.am13
1 files changed, 4 insertions, 9 deletions
diff --git a/caputils/Makefile.am b/caputils/Makefile.am
index 1710d8b587..48b26cc9c2 100644
--- a/caputils/Makefile.am
+++ b/caputils/Makefile.am
@@ -20,11 +20,10 @@
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
include Makefile.common
-include ../Makefile.am.inc
+include $(top_srcdir)/Makefile.am.inc
-if HAVE_WARNINGS_AS_ERRORS
-AM_CLEAN_CFLAGS = -Werror
-endif
+AM_CPPFLAGS += -I$(top_srcdir)/wiretap $(LIBGCRYPT_CFLAGS) \
+ $(LIBGNUTLS_CFLAGS) $(PORTAUDIO_INCLUDES)
noinst_LIBRARIES = libcaputils.a
@@ -71,14 +70,10 @@ libcaputils_a_SOURCES = \
# as it might be running with extra privileges), so this library needs
# to be built that way as well.
#
-libcaputils_a_CFLAGS = $(AM_CLEAN_CFLAGS) $(PIE_CFLAGS)
+libcaputils_a_CFLAGS = $(AM_CFLAGS) $(PIE_CFLAGS)
libcaputils_a_DEPENDENCIES =
-# Common headers
-AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/wiretap $(LIBGCRYPT_CFLAGS) $(LIBGNUTLS_CFLAGS) $(PORTAUDIO_INCLUDES)
-
-
doxygen:
if HAVE_DOXYGEN
$(DOXYGEN) doxygen.cfg