aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2017-11-16 23:55:57 +0000
committerMichael Mann <mmann78@netscape.net>2017-11-18 14:43:10 +0000
commitb695b3e2f72998d66ca4b7a6826d4ce1688060c8 (patch)
treedf1bd7e3db0e50fc5d9b1fa41538fe40420026fa /Makefile.am
parentd8e2bee9ea84ec5123d2023f32c0f0d191834d32 (diff)
Begin cleanup of make-dissector-reg.py
Move registration code to a new register.c file so it is readable. Dissector load points are stored in a generated function pointer array instead. Simplify python script somewhat by not interleaving the plugin and dissector logic. Change-Id: I5ec21270f4e1550a5c911efa7f0dc4fc7fcb13a5 Reviewed-on: https://code.wireshark.org/review/24474 Reviewed-by: João Valverde <j@v6e.pt> Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot Reviewed-by: Michael Mann <mmann78@netscape.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 187212fab1..7e54f517cf 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -395,6 +395,7 @@ EXTCAP_COMMON_SRC = \
SHARK_COMMON_SRC = \
cfile.c \
frame_tvbuff.c \
+ register.c \
sync_pipe_write.c
# wireshark specifics
@@ -677,7 +678,8 @@ randpkt_LDADD = \
@C_ARES_LIBS@
dftest_SOURCES = \
- dftest.c
+ dftest.c \
+ register.c
dftest_CPPFLAGS = $(AM_CPPFLAGS) $(GLIB_CFLAGS)
@@ -723,7 +725,6 @@ pkginclude_HEADERS = \
file.h \
globals.h \
log.h \
- register.h \
ws_attributes.h \
ws_compiler_tests.h \
ws_diag_control.h \
@@ -740,6 +741,7 @@ noinst_HEADERS = \
extcap_spawn.h \
fileset.h \
frame_tvbuff.h \
+ register.h \
ringbuffer.h \
summary.h \
sync_pipe.h \