aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss.ws@gmail.com>2014-09-18 11:47:21 -0400
committerJeff Morriss <jeff.morriss.ws@gmail.com>2015-02-18 01:50:56 +0000
commita5aab2432104fa1c057e4beda37f51b465ae5b9e (patch)
tree4100ae610764c97b5c1f5c35cbd2a10a8aea8e48 /Makefile.am
parent909d891b267852d386f0e47cb4ccd818b7f99176 (diff)
Add an appdata entry for Wireshark.
Based on the one from Richard Hughes. A French translation of the description field is included. Links to two screenshots are provided--they are stored in my home directory on wireshark.org (for lack of a better place that I can put them). Bug: 10479 Change-Id: Ida9b9e46c0fb23a7baff50f98afa597b25b8ca54 Reviewed-on: https://code.wireshark.org/review/4178 Reviewed-by: Jeff Morriss <jeff.morriss.ws@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b0c81cc1f2..5865a5340a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1209,6 +1209,7 @@ EXTRA_DIST = \
services \
wireshark.desktop \
wireshark-mime-package.xml \
+ wireshark.appdata.xml \
wireshark.pc.in \
wka.tmpl \
CMakeLists.txt \
@@ -1425,6 +1426,8 @@ if BUILDING_WIRESHARK
if NOT_OS_X
mkdir -p $(DESTDIR)$(datadir)/mime/packages
install -m 644 $(srcdir)/wireshark-mime-package.xml $(DESTDIR)$(datadir)/mime/packages/wireshark.xml
+ mkdir -p $(DESTDIR)$(datadir)/appdata
+ install -m 644 $(srcdir)/wireshark.appdata.xml $(DESTDIR)$(datadir)/appdata/wireshark.appdata.xml
mkdir -p $(DESTDIR)$(datadir)/applications
if test x$(DESKTOP_FILE_INSTALL) != x ; then \
$(DESKTOP_FILE_INSTALL) --dir $(DESTDIR)$(datadir)/applications $(srcdir)/wireshark.desktop; \