aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPeter Wu <peter@lekensteyn.nl>2016-10-31 23:16:00 +0100
committerDario Lombardo <lomato@gmail.com>2016-11-03 08:55:31 +0000
commit9490f5e98db1c18aa527464373ac149ed3ac285b (patch)
treeb392bb22aeecc1d87cdfcefd879bb21c93e8af24 /Makefile.am
parent4863d813e90b220dc3800829472b3615f47f1428 (diff)
autotools: propagate git version info to distribution tarball
Store the git describe output in the distribution tarball (make dist) and ensure that this version is always used for builds from this tarball. This will prevent the useless "Git Rev Unknown from unknown" output in tar-based builds. It will also prevent git from being invoked in tarball builds. Remove the git branch name since the commit ID (and git tag) in the git describe output is sufficient to identify the source tree. (In SVN, a revision ID had to be paired with a branch name to identify the source tree, in git this is no longer the case.) Change-Id: Iffe142b6efd81e857802eb604d6310cfd301d207 Reviewed-on: https://code.wireshark.org/review/18415 Reviewed-by: João Valverde <j@v6e.pt> Reviewed-by: Peter Wu <peter@lekensteyn.nl> Petri-Dish: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Dario Lombardo <lomato@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 67f23ddbdf..787b1017e4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1202,3 +1202,7 @@ endif
# Update AUTHORS file with entries from git shortlog
gen-authors:
cd $(top_srcdir) && $(PERL) tools/generate_authors.pl AUTHORS.src > AUTHORS
+
+dist-hook:
+ printf "git_description=%s\n" "$$(git -C $(top_srcdir) describe)" \
+ > $(top_distdir)/version.conf