aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2002-04-18 00:29:17 +0000
committerGuy Harris <guy@alum.mit.edu>2002-04-18 00:29:17 +0000
commit92e27e03c14844a3a7f559ea7e70c2ad8e5482d8 (patch)
treea1c94f2a9a8e62f393b8ad3c5a7e1bf8082aad61 /Makefile.am
parenta7c4e209cb65cfdef6881760c97c845fa81821ac (diff)
Add a "proto_register_dcerpc_smb()" which registers ett_ values for
"packet-dcerpc-nt.c", and registers "dcerpc_smb_init()" as an initialization routine. Take the ett_ registration out of the latter routine, and also take out the "do this only once" stuff. Get rid of the initialization routines for netlogon, samr, and spoolss; they just call "dcerpc_smb_init()", which is now an initialization routine of its own. The policy hash initialization should be done before every capture, so it should be done in an initialization routine, and should not do any "do this only once" stuff. It should also be called only once before every capture, rather than 3 times. The ett_ initialization should, however, be done at the same time all other ett_ initialization is done - at protocol registration time - so it should be done in a "proto_register_" routine. This fixes a bug I saw wherein 1) the tree for Unicode strings was open by default and 2) if you closed one and then exited, Ethereal would crash. The problem is that "proto_register_subtree_array()" doesn't expand the array, it just bumps the number of registered ett_ values; the array is allocated in "proto_init()". As such, if you register ett_ values with "proto_register_subtree_array()" *after* "proto_init()" is called - and, even for the first capture, initialization routines are called after "proto_init()" is called - you will get ett_ numbers that go past the number of elements in the array. Move the declaration of "ett_nt_unicode_string" to "packet-dcerpc-nt.h", as it's exported from "packet-dcerpc-nt.c". Get rid of the declaration of "dcerpc_smb_init()" in "packet-dcerpc-nt.h", and make it static, as it's no longer called from outside "packet-dcerpc-nt.c". svn path=/trunk/; revision=5196
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index a950616b44..323619221d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,7 @@
# Makefile.am
# Automake file for Ethereal
#
-# $Id: Makefile.am,v 1.421 2002/04/15 21:47:59 guy Exp $
+# $Id: Makefile.am,v 1.422 2002/04/18 00:29:16 guy Exp $
#
# Ethereal - Network traffic analyzer
# By Gerald Combs <gerald@ethereal.com>
@@ -105,6 +105,7 @@ DISSECTOR_SRC = \
packet-dcerpc-mgmt.c \
packet-dcerpc-ndr.c \
packet-dcerpc-netlogon.c \
+ packet-dcerpc-nt.c \
packet-dcerpc-oxid.c \
packet-dcerpc-reg.c \
packet-dcerpc-remact.c \
@@ -358,6 +359,7 @@ noinst_HEADERS = \
packet-dcerpc-dfs.h \
packet-dcerpc-lsa.h \
packet-dcerpc-netlogon.h \
+ packet-dcerpc-nt.h \
packet-dcerpc-reg.h \
packet-dcerpc-samr.h \
packet-dcerpc-spoolss.h \
@@ -478,8 +480,6 @@ ETHEREAL_COMMON_SRC = \
llcsaps.h \
nlpid.h \
oui.h \
- packet-dcerpc-nt.h \
- packet-dcerpc-nt.c \
pcap-util.c \
pcap-util.h \
ppptypes.h \