aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2011-10-25 19:04:26 +0000
committerGerald Combs <gerald@wireshark.org>2011-10-25 19:04:26 +0000
commit920eaae369533413f79770cd99ee2f3eafc99e6b (patch)
treeb4ff79919f3463219fabd89a14b7640af02916c0 /Makefile.am
parent447de1178dd5b7ee53f1f96dd343121c47c363ea (diff)
In dist-hook, don't try to copy version.conf if it already exists in the
destination directory. svn path=/trunk/; revision=39572
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 682c2d02ec..17bc92451a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1033,7 +1033,7 @@ checkapi: checkapi_local
# prevents make-version from looking for SVN details in the source tarball,
# failing, and then labelling the build as from "SVN version unknown."
dist-hook:
- if test -f $(top_srcdir)/version.conf; then \
+ if test -f $(top_srcdir)/version.conf -a ! -f $(top_distdir)/version.conf ; then \
cp $(top_srcdir)/version.conf $(top_distdir); \
echo "is_release: 1" >> $(top_distdir)/version.conf; \
fi