aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2015-10-15 14:45:45 -0700
committerGerald Combs <gerald@wireshark.org>2015-10-16 20:40:28 +0000
commit7682ae4887fbc45c8d4e3f0d8f21cd9d9093c83b (patch)
treea0aa1521e96a473a8da95d65deb82aa035a12662 /Makefile.am
parent71398e26f7265861e9be75973da6d1aff116e5a8 (diff)
Keep CMake from finding Cygwin's Python.
Try to find Python and set PYTHON_EXECUTABLE on Windows via the registry prior to calling FindPythonInterp. This works around a bug in CMake that prefers Cygwin's Python, which is a symlink, which by default is a text file that contains a Cygwin-specific cookie, which is therefore useless outside of Cygwin. This is avoids the need to pass -DPYTHON_EXECUTABLE=... to CMake. Change-Id: Ife37221b61d920682c20357b6d139a93067a5ad1 Reviewed-on: https://code.wireshark.org/review/11071 Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 2599639ef6..665e37e621 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1333,6 +1333,7 @@ EXTRA_DIST = \
cmake/modules/gmxTestLargeFiles.cmake \
cmake/modules/hhc.cmake \
cmake/modules/LICENSE.txt \
+ cmake/modules/LocatePythonExecutable.cmake \
cmake/modules/LocatePythonModule.cmake \
cmake/modules/readme.txt \
cmake/modules/UseABICheck.cmake \