aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss.ws@gmail.com>2013-10-29 02:28:16 +0000
committerJeff Morriss <jeff.morriss.ws@gmail.com>2013-10-29 02:28:16 +0000
commit58d01512b16728b357b2f6481c592a71c7ab8435 (patch)
tree57c9455c1f04f292f924fb82f8e09d061f3a3424 /Makefile.am
parent766a32779a8b7b90ea53f3fcc4caee5e004bd56e (diff)
Make it so out-of-tree builds (autofoo and cmake) have access to the various
data files (diameter/*, COPYING, manuf) when running *shark from the build directory. Do this by passing in the top-level source directory as a compile-time definition (unfortunately this has to be in the top-level Makefile too because some programs link directly with epan/filesystem.c). The plugins dir is no longer below the datafile directory but rather the progfile directory (if we have one). Handle the special case of AUTHORS-SHORT (a data file but a generated one) by checking the file name before building the path. https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=5664 svn path=/trunk/; revision=52940
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 91285870e9..11443feece 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -579,7 +579,7 @@ dumpcap_LDFLAGS = $(PIE_LDFLAGS)
# Common headers
AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/wiretap \
$(LIBGNUTLS_CFLAGS) $(LIBGCRYPT_CFLAGS) $(LIBSMI_CFLAGS) $(PY_CFLAGS) \
- @LUA_INCLUDES@
+ @LUA_INCLUDES@ -DTOP_SRCDIR=\"$(abs_top_srcdir)\"
#
# Build the version string