aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGilbert Ramirez <gram@alumni.rice.edu>2003-12-06 16:35:20 +0000
committerGilbert Ramirez <gram@alumni.rice.edu>2003-12-06 16:35:20 +0000
commit55a6251e7c52b3610cd8992b541be919a5dca5aa (patch)
tree11537545c74d4f5276cfffaf8cb7b2ad4e6fbba8 /Makefile.am
parent71c8b6077b28245ed7f65e129bf0bcab1066947e (diff)
From Olivier Biot
New "matches" operater in display filter language. Uses PCRE. If a "matches" operator is found in a dfilter while libpcre has not been used to build the binary, then an exception is thrown after using dfilter_fail() to set an apporporiate error message. svn path=/trunk/; revision=9182
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 8 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 775871088c..cb18f1ce0b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,7 @@
# Makefile.am
# Automake file for Ethereal
#
-# $Id: Makefile.am,v 1.663 2003/12/06 06:09:10 gram Exp $
+# $Id: Makefile.am,v 1.664 2003/12/06 16:35:17 gram Exp $
#
# Ethereal - Network traffic analyzer
# By Gerald Combs <gerald@ethereal.com>
@@ -481,7 +481,7 @@ if HAVE_PLUGINS
plugin_libs = \
plugins/acn/acn.la \
plugins/artnet/artnet.la \
- plugins/asn1/asn1.la \
+ plugins/asn1/asn1.la \
plugins/docsis/docsis.la \
plugins/enttec/enttec.la \
plugins/giop/cosnaming.la \
@@ -498,7 +498,7 @@ if ENABLE_STATIC
plugin_ldadd = \
plugins/acn/packet-acn.o \
plugins/artnet/packet-artnet.o \
- plugins/asn1/packet-asn1.o \
+ plugins/asn1/packet-asn1.o \
plugins/docsis/packet-bpkmattr.o \
plugins/docsis/packet-bpkmreq.o \
plugins/docsis/packet-bpkmrsp.o \
@@ -536,7 +536,7 @@ plugin_ldadd = \
plugin_src = \
plugins/acn/packet-acn.c \
plugins/artnet/packet-artnet.c \
- plugins/asn1/packet-asn1.c \
+ plugins/asn1/packet-asn1.c \
plugins/docsis/packet-bpkmattr.c \
plugins/docsis/packet-bpkmreq.c \
plugins/docsis/packet-bpkmrsp.c \
@@ -576,7 +576,7 @@ plugin_ldadd = \
"-dlopen" self \
"-dlopen" plugins/acn/acn.la \
"-dlopen" plugins/artnet/artnet.la \
- "-dlopen" plugins/asn1/asn1.la \
+ "-dlopen" plugins/asn1/asn1.la \
"-dlopen" plugins/docsis/docsis.la \
"-dlopen" plugins/enttec/enttec.la \
"-dlopen" plugins/giop/cosnaming.la \
@@ -930,6 +930,7 @@ ethereal_LDADD = \
$(ethereal_additional_libs) \
@SNMP_LIBS@ @SSL_LIBS@ \
$(plugin_ldadd) \
+ @PCRE_LIBS@ \
@PCAP_LIBS@ @GTK_LIBS@ @ADNS_LIBS@
TETHEREAL_TAP_SRC = \
@@ -978,6 +979,7 @@ tethereal_LDADD = \
$(tethereal_additional_libs) \
@SNMP_LIBS@ @SSL_LIBS@ \
$(plugin_ldadd) \
+ @PCRE_LIBS@ \
@GLIB_LIBS@ -lm \
@PCAP_LIBS@ @SOCKET_LIBS@ @NSL_LIBS@ @ADNS_LIBS@
@@ -1119,6 +1121,7 @@ dftest_LDADD = \
$(dftest_additional_libs) \
@SNMP_LIBS@ @SSL_LIBS@ \
$(plugin_ldadd) \
+ @PCRE_LIBS@ \
@GLIB_LIBS@ -lm \
@PCAP_LIBS@ @SOCKET_LIBS@ @NSL_LIBS@ @ADNS_LIBS@