aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss@ulticom.com>2011-09-08 01:53:41 +0000
committerJeff Morriss <jeff.morriss@ulticom.com>2011-09-08 01:53:41 +0000
commit14ab9387c14db006f74ba2e426ce7603ddf780e3 (patch)
tree254477ad87cde1653028116b843e3982850cfcb1 /Makefile.am
parentc600dbe7c134d203937dedcee0c2ec56dbccb356 (diff)
Revert rev 38340 (which was itself a reversion of 34807): if we can't find the
SVN version, indicate that the SVN version is unknown. This puts back the fix for bug 1413. Add a new version.conf option for make-version which tell is "this is a build from a release tarball." When that option is present do not try to use SVN to determine the SVN version, just use whatever SVN information shipped in the tarball. If version.conf is present in the source tree (as it is only in the release branches), deliver it in the source tarball but only after setting the "this is a release tarball" option. All of this means that that builds from release-branch tarballs will report the SVN version of the release tarball rather than "unknown." This addresses the issue reported in http://ask.wireshark.org/questions/5376/wireshark-161-title-shows-svn-rev-unknown-from-unknown Builds from trunk (including the source tarballs) will continue to report that the SVN version is unknown. (Maybe that, too, should be changed?) svn path=/trunk/; revision=38933
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am25
1 files changed, 17 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index f7b8adec67..9da02e2ad2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -810,7 +810,7 @@ EXTRA_DIST = \
$(dtds_DATA) \
$(radius_DATA) \
$(tpncp_DATA) \
- $(ui_DATA) \
+ $(ui_DATA) \
$(wimaxasncp_DATA) \
randpkt.c \
smi_modules \
@@ -866,16 +866,16 @@ EXTRA_DIST = \
cmake/modules/UseMakeDissectorReg.cmake \
cmake/modules/UseMakeTapReg.cmake \
cmake/modules/readme.txt \
- win32/Makefile.nmake \
- win32/file_dlg_win32.c \
- win32/file_dlg_win32.h \
+ win32/Makefile.nmake \
+ win32/file_dlg_win32.c \
+ win32/file_dlg_win32.h \
win32/print_win32.c \
win32/print_win32.h \
CPackConfig.txt \
- all.vcproj \
- dumpcap.vcproj \
- packaging.vcproj \
- tshark.vcproj \
+ all.vcproj \
+ dumpcap.vcproj \
+ packaging.vcproj \
+ tshark.vcproj \
wireshark.vcproj
install-exec-hook:
@@ -1024,3 +1024,12 @@ checkapi: checkapi_local
cd ../dissectors && $(MAKE) checkapi
cd ../../plugins && $(MAKE) checkapi
cd ../wsutil && $(MAKE) checkapi
+
+# When we build a release tarball, tell make-version that it is such. This
+# prevents make-version from looking for SVN details in the source tarball,
+# failing, and then labelling the build as from "SVN version unknown."
+dist-hook:
+ if test -f $(top_srcdir)/version.conf; then \
+ cp $(top_srcdir)/version.conf $(top_distdir); \
+ echo "is_release: 1" >> $(top_distdir)/version.conf; \
+ fi